summaryrefslogtreecommitdiffstats
path: root/recipes-security/smw/keyctl-caam_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-security/smw/keyctl-caam_git.bb')
-rw-r--r--recipes-security/smw/keyctl-caam_git.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/recipes-security/smw/keyctl-caam_git.bb b/recipes-security/smw/keyctl-caam_git.bb
new file mode 100644
index 00000000..25a5f656
--- /dev/null
+++ b/recipes-security/smw/keyctl-caam_git.bb
@@ -0,0 +1,23 @@
1# Copyright 2020-2022 NXP
2
3SUMMARY = "NXP i.MX CAAM Keyctl"
4DESCRIPTION = "NXP i.MX keyctl tool to manage CAAM Keys"
5SECTION = "base"
6LICENSE = "BSD-3-Clause"
7LIC_FILES_CHKSUM = "file://COPYING;md5=8636bd68fc00cc6a3809b7b58b45f982"
8
9SRCBRANCH = "master"
10SRC_URI = "git://github.com/nxp-imx/keyctl_caam.git;protocol=https;branch=${SRCBRANCH}"
11
12SRCREV = "81dc06cdb9c4d0d4ba10459d85af9a8603774948"
13
14S = "${WORKDIR}/git"
15
16TARGET_CC_ARCH += "${LDFLAGS}"
17
18do_install () {
19 oe_runmake DESTDIR=${D} install
20}
21
22COMPATIBLE_MACHINE = "(imx-generic-bsp)"
23