summaryrefslogtreecommitdiffstats
path: root/recipes-security/optee-imx/optee-os/0002-optee-enable-clang-support.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-security/optee-imx/optee-os/0002-optee-enable-clang-support.patch')
-rw-r--r--recipes-security/optee-imx/optee-os/0002-optee-enable-clang-support.patch34
1 files changed, 34 insertions, 0 deletions
diff --git a/recipes-security/optee-imx/optee-os/0002-optee-enable-clang-support.patch b/recipes-security/optee-imx/optee-os/0002-optee-enable-clang-support.patch
new file mode 100644
index 00000000..096579c0
--- /dev/null
+++ b/recipes-security/optee-imx/optee-os/0002-optee-enable-clang-support.patch
@@ -0,0 +1,34 @@
1From c67f63d4e7bbe7b21b4c9ef49ae84c6725794aa9 Mon Sep 17 00:00:00 2001
2From: Brett Warren <brett.warren@arm.com>
3Date: Wed, 23 Sep 2020 09:27:34 +0100
4Subject: [PATCH 2/4] optee: enable clang support
5
6When compiling with clang, the LIBGCC_LOCATE_CFLAG variable used
7to provide a sysroot wasn't included, which results in not locating
8compiler-rt. This is mitigated by including the variable as ammended.
9
10Upstream-Status: Pending
11ChangeId: 8ba69a4b2eb8ebaa047cb266c9aa6c2c3da45701
12Signed-off-by: Brett Warren <brett.warren@arm.com>
13Signed-off-by: Oleksandr Suvorov <oleksandr.suvorov@foundries.io>
14---
15
16 mk/clang.mk | 2 +-
17 1 file changed, 1 insertion(+), 1 deletion(-)
18
19diff --git a/mk/clang.mk b/mk/clang.mk
20index a045beee8..1ebe2f702 100644
21--- a/mk/clang.mk
22+++ b/mk/clang.mk
23@@ -30,7 +30,7 @@ comp-cflags-warns-clang := -Wno-language-extension-token \
24
25 # Note, use the compiler runtime library (libclang_rt.builtins.*.a) instead of
26 # libgcc for clang
27-libgcc$(sm) := $(shell $(CC$(sm)) $(CFLAGS$(arch-bits-$(sm))) \
28+libgcc$(sm) := $(shell $(CC$(sm)) $(LIBGCC_LOCATE_CFLAGS) $(CFLAGS$(arch-bits-$(sm))) \
29 -rtlib=compiler-rt -print-libgcc-file-name 2> /dev/null)
30
31 # Core ASLR relies on the executable being ready to run from its preferred load
32--
332.40.1
34