summaryrefslogtreecommitdiffstats
path: root/recipes-multimedia/imx-vpuwrap/imx-vpuwrap_4.6.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-multimedia/imx-vpuwrap/imx-vpuwrap_4.6.2.bb')
-rw-r--r--recipes-multimedia/imx-vpuwrap/imx-vpuwrap_4.6.2.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/recipes-multimedia/imx-vpuwrap/imx-vpuwrap_4.6.2.bb b/recipes-multimedia/imx-vpuwrap/imx-vpuwrap_4.6.2.bb
new file mode 100644
index 00000000..03702b16
--- /dev/null
+++ b/recipes-multimedia/imx-vpuwrap/imx-vpuwrap_4.6.2.bb
@@ -0,0 +1,29 @@
1# Copyright (C) 2013-2016 Freescale Semiconductor
2# Copyright (C) 2017-2020 NXP
3# Released under the MIT license (see COPYING.MIT for the terms)
4
5DESCRIPTION = "Freescale Multimedia VPU wrapper"
6LICENSE = "Proprietary"
7SECTION = "multimedia"
8LIC_FILES_CHKSUM = "file://COPYING;md5=e565271ec9a80ce47abbddc4bffe56fa"
9
10DEPENDS = "virtual/imxvpu"
11DEPENDS:append:mx8mp = " imx-vpu-hantro-vc"
12
13SRC_URI = "git://github.com/NXP/imx-vpuwrap.git;protocol=https;branch=${SRCBRANCH}"
14
15SRCBRANCH = "MM_04.06.02_2108_L5.10.y"
16SRCREV = "f09ceba7bcf733b1b27e57462496d3b81ca28e50"
17
18S = "${WORKDIR}/git"
19
20inherit autotools pkgconfig
21
22do_install:append() {
23 # FIXME: Drop examples for now
24 rm -r ${D}${datadir}
25}
26
27PACKAGE_ARCH = "${MACHINE_ARCH}"
28
29COMPATIBLE_MACHINE = "(imxvpu)"