summaryrefslogtreecommitdiffstats
path: root/recipes-multimedia/imx-vpuwrap/imx-vpuwrap_4.4.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-multimedia/imx-vpuwrap/imx-vpuwrap_4.4.0.bb')
-rw-r--r--recipes-multimedia/imx-vpuwrap/imx-vpuwrap_4.4.0.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/recipes-multimedia/imx-vpuwrap/imx-vpuwrap_4.4.0.bb b/recipes-multimedia/imx-vpuwrap/imx-vpuwrap_4.4.0.bb
new file mode 100644
index 00000000..eeb3e548
--- /dev/null
+++ b/recipes-multimedia/imx-vpuwrap/imx-vpuwrap_4.4.0.bb
@@ -0,0 +1,32 @@
1# Copyright (C) 2013-2016 Freescale Semiconductor
2# Copyright 2017 NXP
3# Copyright 2018 (C) O.S. Systems Software LTDA.
4# Released under the MIT license (see COPYING.MIT for the terms)
5DESCRIPTION = "Freescale Multimedia VPU wrapper"
6DEPENDS = "virtual/imxvpu"
7LICENSE = "Proprietary"
8SECTION = "multimedia"
9LIC_FILES_CHKSUM = "file://COPYING;md5=ab61cab9599935bfe9f700405ef00f28"
10
11# For backwards compatibility
12PROVIDES += "libfslvpuwrap"
13RREPLACES_${PN} = "libfslvpuwrap"
14RPROVIDES_${PN} = "libfslvpuwrap"
15RCONFLICTS_${PN} = "libfslvpuwrap"
16
17SRC_URI = "${FSL_MIRROR}/${PN}-${PV}.bin;fsl-eula=true"
18
19SRC_URI[md5sum] = "dc69b4df71bca964cccb19a9b46de591"
20SRC_URI[sha256sum] = "5adb17386584bdd39faa5004b4ceb83987f1519acf4466e15b42672def66f49d"
21
22inherit fsl-eula-unpack autotools pkgconfig
23
24do_install_append() {
25 # FIXME: Drop examples for now
26 rm -r ${D}${datadir}
27}
28
29INSANE_SKIP_imx-vpuwrap = "file-rdeps"
30
31PACKAGE_ARCH = "${MACHINE_ARCH}"
32COMPATIBLE_MACHINE = "(mx6q|mx6dl|mx8mq)"