summaryrefslogtreecommitdiffstats
path: root/recipes-multimedia/imx-parser/imx-parser_4.8.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-multimedia/imx-parser/imx-parser_4.8.2.bb')
-rw-r--r--recipes-multimedia/imx-parser/imx-parser_4.8.2.bb44
1 files changed, 44 insertions, 0 deletions
diff --git a/recipes-multimedia/imx-parser/imx-parser_4.8.2.bb b/recipes-multimedia/imx-parser/imx-parser_4.8.2.bb
new file mode 100644
index 00000000..4b59eb2f
--- /dev/null
+++ b/recipes-multimedia/imx-parser/imx-parser_4.8.2.bb
@@ -0,0 +1,44 @@
1# Copyright (C) 2012-2018 O.S. Systems Software LTDA.
2# Copyright (C) 2012-2016 Freescale Semiconductor
3# Copyright (C) 2017-2023 NXP
4# Released under the MIT license (see COPYING.MIT for the terms)
5DESCRIPTION = "Freescale Multimedia parser libs"
6LICENSE = "Proprietary"
7SECTION = "multimedia"
8LIC_FILES_CHKSUM = "file://COPYING;md5=2827219e81f28aba7c6a569f7c437fa7"
9
10# For backwards compatibility
11PROVIDES += "libfslparser"
12RREPLACES:${PN} = "libfslparser"
13RPROVIDES:${PN} = "libfslparser"
14RCONFLICTS:${PN} = "libfslparser"
15
16SRC_URI = "${FSL_MIRROR}/${BP}.bin;fsl-eula=true"
17SRC_URI[md5sum] = "2e862fce70bc82649057ed552473d982"
18SRC_URI[sha256sum] = "20f326821ced5d6855f81794b66ec1f0c334e9ec7a9be1368a9b4dc501b666c6"
19
20inherit fsl-eula-unpack autotools pkgconfig
21
22# Choose between 32-bit and 64-bit binaries and between Soft Float-Point and Hard Float-Point
23EXTRA_OECONF = "${@bb.utils.contains('TUNE_FEATURES', 'aarch64', '--enable-armv8', \
24 bb.utils.contains('TUNE_FEATURES', 'callconvention-hard', '--enable-fhw', '--enable-fsw', d), d)}"
25
26INHIBIT_PACKAGE_STRIP = "1"
27INHIBIT_PACKAGE_DEBUG_SPLIT = "1"
28
29python __set_insane_skip() {
30 # FIXME: All binaries lack GNU_HASH in elf binary but as we don't have
31 # the source we cannot fix it. Disable the insane check for now.
32 # FIXME: gst-fsl-plugin looks for the .so files so we need to deploy those
33 for p in d.getVar('PACKAGES').split():
34 d.setVar("INSANE_SKIP:%s" % p, "ldflags dev-so textrel")
35}
36
37do_package_qa[prefuncs] += "__set_insane_skip"
38
39# FIXME: gst-fsl-plugin looks for the .so files so we need to deploy those
40FILES:${PN} += "${libdir}/imx-mm/*/*${SOLIBS} ${libdir}/imx-mm/*/*${SOLIBSDEV}"
41
42INHIBIT_SYSROOT_STRIP = "1"
43
44COMPATIBLE_MACHINE = "(imx-nxp-bsp)"