summaryrefslogtreecommitdiffstats
path: root/recipes-multimedia/imx-parser/imx-parser_4.3.5.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-multimedia/imx-parser/imx-parser_4.3.5.bb')
-rw-r--r--recipes-multimedia/imx-parser/imx-parser_4.3.5.bb45
1 files changed, 45 insertions, 0 deletions
diff --git a/recipes-multimedia/imx-parser/imx-parser_4.3.5.bb b/recipes-multimedia/imx-parser/imx-parser_4.3.5.bb
new file mode 100644
index 00000000..da031e84
--- /dev/null
+++ b/recipes-multimedia/imx-parser/imx-parser_4.3.5.bb
@@ -0,0 +1,45 @@
1# Copyright (C) 2012-2018 O.S. Systems Software LTDA.
2# Copyright (C) 2012-2016 Freescale Semiconductor
3# Copyright 2017 NXP
4# Released under the MIT license (see COPYING.MIT for the terms)
5DESCRIPTION = "Freescale Multimedia parser libs"
6LICENSE = "Proprietary"
7SECTION = "multimedia"
8LIC_FILES_CHKSUM = "file://COPYING;md5=75abe2fa1d16ca79f87cde926f05f72d"
9
10# For backwards compatibility
11PROVIDES += "libfslparser"
12RREPLACES_${PN} = "libfslparser"
13RPROVIDES_${PN} = "libfslparser"
14RCONFLICTS_${PN} = "libfslparser"
15
16SRC_URI = "${FSL_MIRROR}/${PN}-${PV}.bin;fsl-eula=true"
17SRC_URI[md5sum] = "54fcf59ec947955aceae51831d3ccb46"
18SRC_URI[sha256sum] = "9cd8c49a0bb1050afcfbcc7a677a348443fda4ecacb621cc6e38897619e27c67"
19
20inherit fsl-eula-unpack autotools pkgconfig
21
22# Choose between Soft Float-Point and Hard Float-Point
23EXTRA_OECONF = "${@bb.utils.contains('TUNE_FEATURES', 'callconvention-hard', '--enable-fhw', '--enable-fsw', d)}"
24
25INHIBIT_PACKAGE_STRIP = "1"
26INHIBIT_PACKAGE_DEBUG_SPLIT = "1"
27
28python __set_insane_skip() {
29 # FIXME: All binaries lack GNU_HASH in elf binary but as we don't have
30 # the source we cannot fix it. Disable the insane check for now.
31 # FIXME: gst-fsl-plugin looks for the .so files so we need to deploy those
32 for p in d.getVar('PACKAGES', True).split():
33 d.setVar("INSANE_SKIP_%s" % p, "ldflags dev-so textrel")
34}
35
36do_package_qa[prefuncs] += "__set_insane_skip"
37
38# FIXME: gst-fsl-plugin looks for the .so files so we need to deploy those
39FILES_${PN} += "${libdir}/imx-mm/*/*${SOLIBS} ${libdir}/imx-mm/*/*${SOLIBSDEV}"
40
41PACKAGE_ARCH = "${MACHINE_ARCH}"
42
43INHIBIT_SYSROOT_STRIP = "1"
44
45COMPATIBLE_MACHINE = "(mx6|mx7|mx8)"