diff options
Diffstat (limited to 'recipes-multimedia/gstreamer')
-rw-r--r-- | recipes-multimedia/gstreamer/imx-gst1.0-plugin/0001-imx-gst1.0-plugin-Fix-ion.h-header-inclusion-to-be-s.patch | 44 | ||||
-rw-r--r-- | recipes-multimedia/gstreamer/imx-gst1.0-plugin_4.4.2.bb (renamed from recipes-multimedia/gstreamer/imx-gst1.0-plugin_4.4.0.bb) | 10 |
2 files changed, 50 insertions, 4 deletions
diff --git a/recipes-multimedia/gstreamer/imx-gst1.0-plugin/0001-imx-gst1.0-plugin-Fix-ion.h-header-inclusion-to-be-s.patch b/recipes-multimedia/gstreamer/imx-gst1.0-plugin/0001-imx-gst1.0-plugin-Fix-ion.h-header-inclusion-to-be-s.patch new file mode 100644 index 00000000..4e861a5d --- /dev/null +++ b/recipes-multimedia/gstreamer/imx-gst1.0-plugin/0001-imx-gst1.0-plugin-Fix-ion.h-header-inclusion-to-be-s.patch | |||
@@ -0,0 +1,44 @@ | |||
1 | From e4c96421700ecd008814bceceaf03f0ee9323c02 Mon Sep 17 00:00:00 2001 | ||
2 | From: Yuqing Zhu <carol.zhu@nxp.com> | ||
3 | Date: Thu, 27 Sep 2018 16:00:55 +0800 | ||
4 | Subject: [PATCH] imx-gst1.0-plugin: Fix ion.h header inclusion to be standard | ||
5 | |||
6 | NXP "solution" was to manually copy the header to include/linux. | ||
7 | Let's point the Makefile to the proper (mainline) location instead: | ||
8 | https://elixir.bootlin.com/linux/v4.17/source/drivers/staging/android/uapi/ion.h | ||
9 | |||
10 | Signed-off-by: Yuqing Zhu <carol.zhu@nxp.com> | ||
11 | --- | ||
12 | configure.ac | 2 +- | ||
13 | libs/gstimxcommon.c | 2 +- | ||
14 | 2 files changed, 2 insertions(+), 2 deletions(-) | ||
15 | |||
16 | diff --git a/configure.ac b/configure.ac | ||
17 | index 7b2709d..d94e3a8 100755 | ||
18 | --- a/configure.ac | ||
19 | +++ b/configure.ac | ||
20 | @@ -216,7 +216,7 @@ dnl check ion allocator headfile | ||
21 | old_CFLAGS=$CFLAGS | ||
22 | PKG_CHECK_MODULES(GST, gstreamer-$GST_MAJORMINOR >= 1.14, CFLAGS="$CFLAGS `$PKG_CONFIG --cflags gstreamer-allocators-1.0`",\ | ||
23 | CFLAGS="$CFLAGS `$PKG_CONFIG --cflags gstreamer-bad-allocators-1.0`") | ||
24 | -AC_CHECK_HEADERS([linux/ion.h gst/allocators/gstionmemory.h], HAVE_ION="yes", HAVE_ION="no") | ||
25 | +AC_CHECK_HEADERS([ion.h gst/allocators/gstionmemory.h], HAVE_ION="yes", HAVE_ION="no") | ||
26 | AM_CONDITIONAL(USE_ION, test "x$HAVE_ION" = "xyes") | ||
27 | CFLAGS=$old_CFLAGS | ||
28 | |||
29 | diff --git a/libs/gstimxcommon.c b/libs/gstimxcommon.c | ||
30 | index eb808b9..c02ab5f 100644 | ||
31 | --- a/libs/gstimxcommon.c | ||
32 | +++ b/libs/gstimxcommon.c | ||
33 | @@ -26,7 +26,7 @@ | ||
34 | #include <linux/version.h> | ||
35 | #include <linux/dma-buf.h> | ||
36 | #ifdef USE_ION | ||
37 | -#include <linux/ion.h> | ||
38 | +#include <ion.h> | ||
39 | #endif | ||
40 | const char *dev_ion = "/dev/ion"; | ||
41 | |||
42 | -- | ||
43 | 1.9.1 | ||
44 | |||
diff --git a/recipes-multimedia/gstreamer/imx-gst1.0-plugin_4.4.0.bb b/recipes-multimedia/gstreamer/imx-gst1.0-plugin_4.4.2.bb index 00182bbd..07a52c67 100644 --- a/recipes-multimedia/gstreamer/imx-gst1.0-plugin_4.4.0.bb +++ b/recipes-multimedia/gstreamer/imx-gst1.0-plugin_4.4.2.bb | |||
@@ -21,10 +21,12 @@ LIC_FILES_CHKSUM = "file://COPYING-LGPL-2;md5=5f30f0716dfdd0d91eb439ebec522ec2 \ | |||
21 | file://COPYING-LGPL-2.1;md5=fbc093901857fcd118f065f900982c24" | 21 | file://COPYING-LGPL-2.1;md5=fbc093901857fcd118f065f900982c24" |
22 | 22 | ||
23 | IMXGST_SRC ?= "git://source.codeaurora.org/external/imx/imx-gst1.0-plugin.git;protocol=https" | 23 | IMXGST_SRC ?= "git://source.codeaurora.org/external/imx/imx-gst1.0-plugin.git;protocol=https" |
24 | SRCBRANCH = "MM_04.04.00_1805_L4.9.88_MX8QXP_BETA2" | 24 | SRCBRANCH = "MM_04.04.02_1808_L4.9.123_MX8MM_GA" |
25 | 25 | ||
26 | SRC_URI = "${IMXGST_SRC};branch=${SRCBRANCH}" | 26 | SRC_URI = "${IMXGST_SRC};branch=${SRCBRANCH} \ |
27 | SRCREV = "ded3b04018ca71306da9bc38b0037b9ea99abd29" | 27 | file://0001-imx-gst1.0-plugin-Fix-ion.h-header-inclusion-to-be-s.patch \ |
28 | " | ||
29 | SRCREV = "23dd0315c7087e1c8eba836b9a458d7906187c7e" | ||
28 | 30 | ||
29 | S = "${WORKDIR}/git" | 31 | S = "${WORKDIR}/git" |
30 | 32 | ||
@@ -44,7 +46,7 @@ PLATFORM_mx8 = "MX8" | |||
44 | 46 | ||
45 | # Todo add a mechanism to map possible build targets | 47 | # Todo add a mechanism to map possible build targets |
46 | EXTRA_OECONF = "PLATFORM=${PLATFORM} \ | 48 | EXTRA_OECONF = "PLATFORM=${PLATFORM} \ |
47 | CPPFLAGS="-I${STAGING_KERNEL_BUILDDIR}/include/generated/uapi -I${STAGING_KERNEL_DIR}/include/uapi -I${STAGING_KERNEL_DIR}/include" \ | 49 | CPPFLAGS="-I${STAGING_KERNEL_BUILDDIR}/include/generated/uapi -I${STAGING_KERNEL_DIR}/include/uapi -I${STAGING_KERNEL_DIR}/include -I${STAGING_KERNEL_DIR}/drivers/staging/android/uapi" \ |
48 | CROSS_ROOT=${PKG_CONFIG_SYSROOT_DIR} \ | 50 | CROSS_ROOT=${PKG_CONFIG_SYSROOT_DIR} \ |
49 | ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', bb.utils.contains('DISTRO_FEATURES', 'x11', '--disable-x11', '', d), '', d)}" | 51 | ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', bb.utils.contains('DISTRO_FEATURES', 'x11', '--disable-x11', '', d), '', d)}" |
50 | 52 | ||