summaryrefslogtreecommitdiffstats
path: root/recipes-multimedia/gstreamer/gstreamer1.0_1.16.imx.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-multimedia/gstreamer/gstreamer1.0_1.16.imx.bb')
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0_1.16.imx.bb87
1 files changed, 47 insertions, 40 deletions
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0_1.16.imx.bb b/recipes-multimedia/gstreamer/gstreamer1.0_1.16.imx.bb
index 3c9653a6..2bcf2562 100644
--- a/recipes-multimedia/gstreamer/gstreamer1.0_1.16.imx.bb
+++ b/recipes-multimedia/gstreamer/gstreamer1.0_1.16.imx.bb
@@ -6,13 +6,9 @@ BUGTRACKER = "https://bugzilla.gnome.org/enter_bug.cgi?product=Gstreamer"
6SECTION = "multimedia" 6SECTION = "multimedia"
7LICENSE = "LGPLv2+" 7LICENSE = "LGPLv2+"
8 8
9DEPENDS = "glib-2.0 glib-2.0-native libcap libxml2 bison-native flex-native elfutils" 9DEPENDS = "glib-2.0 glib-2.0-native libcap libxml2 bison-native flex-native"
10 10
11inherit autotools pkgconfig gettext upstream-version-is-even gobject-introspection gtk-doc 11inherit meson pkgconfig gettext upstream-version-is-even gobject-introspection gtk-doc
12
13# This way common/m4/introspection.m4 will come first
14# (it has a custom INTROSPECTION_INIT macro, and so must be used instead of our common introspection.m4 file)
15acpaths = "-I ${S}/common/m4 -I ${S}/m4"
16 12
17LIC_FILES_CHKSUM = "file://COPYING;md5=6762ed442b3822387a51c92d928ead0d \ 13LIC_FILES_CHKSUM = "file://COPYING;md5=6762ed442b3822387a51c92d928ead0d \
18 file://gst/gst.h;beginline=1;endline=21;md5=e059138481205ee2c6fc1c079c016d0d" 14 file://gst/gst.h;beginline=1;endline=21;md5=e059138481205ee2c6fc1c079c016d0d"
@@ -23,55 +19,66 @@ SRCBRANCH = "MM_04.05.01_1909_L4.19.35"
23 19
24SRC_URI = " \ 20SRC_URI = " \
25 ${GST1.0_SRC};branch=${SRCBRANCH} \ 21 ${GST1.0_SRC};branch=${SRCBRANCH} \
26 file://0001-introspection.m4-prefix-pkgconfig-paths-with-PKG_CON.patch \
27 file://gtk-doc-tweaks.patch \
28 file://0001-gst-gstpluginloader.c-when-env-var-is-set-do-not-fal.patch \ 22 file://0001-gst-gstpluginloader.c-when-env-var-is-set-do-not-fal.patch \
23 file://0002-meson-build-gir-even-when-cross-compiling-if-introsp.patch \
24 file://0003-meson-Add-valgrind-feature.patch \
25 file://0004-meson-Add-option-for-installed-tests.patch \
26 file://capfix.patch \
29" 27"
30SRCREV = "a4c220605ac0923596b89f4f07c05d235bc09259" 28SRCREV = "a4c220605ac0923596b89f4f07c05d235bc09259"
31 29
32DEFAULT_PREFERENCE = "-1" 30S = "${WORKDIR}/git"
33
34EXTRA_AUTORECONF = ""
35
36PACKAGECONFIG ??= ""
37 31
38PACKAGECONFIG[debug] = "--enable-debug,--disable-debug" 32DEFAULT_PREFERENCE = "-1"
39PACKAGECONFIG[tests] = "--enable-tests,--disable-tests"
40PACKAGECONFIG[valgrind] = "--enable-valgrind,--disable-valgrind,valgrind,"
41PACKAGECONFIG[gst-tracer-hooks] = "--enable-gst-tracer-hooks,--disable-gst-tracer-hooks,"
42 33
43EXTRA_OECONF = " \ 34PACKAGECONFIG ??= "${@bb.utils.contains('PTEST_ENABLED', '1', 'tests', '', d)} \
44 --disable-dependency-tracking \ 35 check \
45 --disable-examples \ 36 debug \
37 tools"
38
39PACKAGECONFIG[debug] = "-Dgst_debug=true,-Dgst_debug=false"
40PACKAGECONFIG[tracer-hooks] = "-Dtracer_hooks=true,-Dtracer_hooks=false"
41PACKAGECONFIG[check] = "-Dcheck=enabled,-Dcheck=disabled"
42PACKAGECONFIG[tests] = "-Dtests=enabled -Dinstalled-tests=true,-Dtests=disabled -Dinstalled-tests=false"
43PACKAGECONFIG[valgrind] = "-Dvalgrind=enabled,-Dvalgrind=disabled,valgrind,"
44PACKAGECONFIG[unwind] = "-Dlibunwind=enabled,-Dlibunwind=disabled,libunwind"
45PACKAGECONFIG[dw] = "-Dlibdw=enabled,-Dlibdw=disabled,elfutils"
46PACKAGECONFIG[bash-completion] = "-Dbash-completion=enabled,-Dbash-completion=disabled,bash-completion"
47PACKAGECONFIG[tools] = "-Dtools=enabled,-Dtools=disabled"
48PACKAGECONFIG[setcap] = "-Dsetcap=enabled,-Dsetcap=disabled,libcap libcap-native"
49
50# TODO: put this in a gettext.bbclass patch
51def gettext_oemeson(d):
52 if d.getVar('USE_NLS') == 'no':
53 return '-Dnls=disabled'
54 # Remove the NLS bits if USE_NLS is no or INHIBIT_DEFAULT_DEPS is set
55 if d.getVar('INHIBIT_DEFAULT_DEPS') and not oe.utils.inherits(d, 'cross-canadian'):
56 return '-Dnls=disabled'
57 return '-Dnls=enabled'
58
59EXTRA_OEMESON += " \
60 -Dexamples=disabled \
61 -Ddbghelp=disabled \
62 ${@gettext_oemeson(d)} \
46" 63"
47 64
48CACHED_CONFIGUREVARS += "ac_cv_header_valgrind_valgrind_h=no" 65GTKDOC_MESON_OPTION = "gtk_doc"
66GTKDOC_MESON_ENABLE_FLAG = "enabled"
67GTKDOC_MESON_DISABLE_FLAG = "disabled"
49 68
50# musl libc generates warnings if <sys/poll.h> is included directly 69GIR_MESON_ENABLE_FLAG = "enabled"
51CACHED_CONFIGUREVARS += "ac_cv_header_sys_poll_h=no" 70GIR_MESON_DISABLE_FLAG = "disabled"
52 71
53PACKAGES += "${PN}-bash-completion" 72PACKAGES += "${PN}-bash-completion"
54 73
74# Add the core element plugins to the main package
55FILES_${PN} += "${libdir}/gstreamer-1.0/*.so" 75FILES_${PN} += "${libdir}/gstreamer-1.0/*.so"
56FILES_${PN}-dev += "${libdir}/gstreamer-1.0/*.la ${libdir}/gstreamer-1.0/*.a ${libdir}/gstreamer-1.0/include" 76FILES_${PN}-dev += "${libdir}/gstreamer-1.0/*.a ${libdir}/gstreamer-1.0/include"
57FILES_${PN}-dev += "${datadir}/gdb/* ${datadir}/gstreamer-1.0/gdb/*"
58FILES_${PN}-bash-completion += "${datadir}/bash-completion/completions/ ${datadir}/bash-completion/helpers/gst*" 77FILES_${PN}-bash-completion += "${datadir}/bash-completion/completions/ ${datadir}/bash-completion/helpers/gst*"
78FILES_${PN}-dbg += "${datadir}/gdb ${datadir}/gstreamer-1.0/gdb ${datadir}/glib-2.0/gdb"
59 79
60RRECOMMENDS_${PN}_qemux86 += "kernel-module-snd-ens1370 kernel-module-snd-rawmidi" 80CVE_PRODUCT = "gstreamer"
61RRECOMMENDS_${PN}_qemux86-64 += "kernel-module-snd-ens1370 kernel-module-snd-rawmidi"
62
63delete_pkg_m4_file() {
64 # This m4 file is out of date and is missing PKG_CONFIG_SYSROOT_PATH tweaks which we need for introspection
65 rm "${S}/common/m4/pkg.m4" || true
66 rm -f "${S}/common/m4/gtk-doc.m4"
67}
68
69do_configure[prefuncs] += "delete_pkg_m4_file"
70 81
71do_compile_prepend() { 82require recipes-multimedia/gstreamer/gstreamer1.0-ptest.inc
72 export GIR_EXTRA_LIBS_PATH="${B}/gst/.libs:${B}/libs/gst/base/.libs"
73}
74
75S = "${WORKDIR}/git"
76 83
77COMPATIBLE_MACHINE = "(mx6|mx7|mx8)" 84COMPATIBLE_MACHINE = "(mx6|mx7|mx8)"