summaryrefslogtreecommitdiffstats
path: root/recipes-multimedia/gstreamer/files
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-multimedia/gstreamer/files')
-rw-r--r--recipes-multimedia/gstreamer/files/0001-gst-gstpluginloader.c-when-env-var-is-set-do-not-fal.patch35
-rw-r--r--recipes-multimedia/gstreamer/files/0001-introspection.m4-prefix-pkgconfig-paths-with-PKG_CON.patch42
-rw-r--r--recipes-multimedia/gstreamer/files/gtk-doc-tweaks.patch47
3 files changed, 0 insertions, 124 deletions
diff --git a/recipes-multimedia/gstreamer/files/0001-gst-gstpluginloader.c-when-env-var-is-set-do-not-fal.patch b/recipes-multimedia/gstreamer/files/0001-gst-gstpluginloader.c-when-env-var-is-set-do-not-fal.patch
deleted file mode 100644
index 67a872cd..00000000
--- a/recipes-multimedia/gstreamer/files/0001-gst-gstpluginloader.c-when-env-var-is-set-do-not-fal.patch
+++ /dev/null
@@ -1,35 +0,0 @@
1From a1d7c582392c8bc87fa9411af77b20e011944357 Mon Sep 17 00:00:00 2001
2From: Alexander Kanavin <alex.kanavin@gmail.com>
3Date: Thu, 25 Jan 2018 17:55:02 +0200
4Subject: [PATCH] gst/gstpluginloader.c: when env var is set do not fall
5 through to system plugin scanner
6
7If we set a custom GST_PLUGIN_SCANNER env var, then we probably want to use that and only that.
8
9Falling through to the one installed on the system is problamatic in cross-compilation
10environemnts, regardless of whether one pointed to by the env var succeeded or failed.
11
12Upstream-Status: Pending
13Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com>
14---
15 gst/gstpluginloader.c | 4 +---
16 1 file changed, 1 insertion(+), 3 deletions(-)
17
18diff --git a/gst/gstpluginloader.c b/gst/gstpluginloader.c
19index 430829d..3a75731 100644
20--- a/gst/gstpluginloader.c
21+++ b/gst/gstpluginloader.c
22@@ -471,9 +471,7 @@ gst_plugin_loader_spawn (GstPluginLoader * loader)
23 helper_bin = g_strdup (env);
24 res = gst_plugin_loader_try_helper (loader, helper_bin);
25 g_free (helper_bin);
26- }
27-
28- if (!res) {
29+ } else {
30 GST_LOG ("Trying installed plugin scanner");
31
32 #ifdef G_OS_WIN32
33--
342.15.1
35
diff --git a/recipes-multimedia/gstreamer/files/0001-introspection.m4-prefix-pkgconfig-paths-with-PKG_CON.patch b/recipes-multimedia/gstreamer/files/0001-introspection.m4-prefix-pkgconfig-paths-with-PKG_CON.patch
deleted file mode 100644
index 2cab87f9..00000000
--- a/recipes-multimedia/gstreamer/files/0001-introspection.m4-prefix-pkgconfig-paths-with-PKG_CON.patch
+++ /dev/null
@@ -1,42 +0,0 @@
1From 90916f96262fa7b27a0a99788c69f9fd6df11000 Mon Sep 17 00:00:00 2001
2From: Alexander Kanavin <alex.kanavin@gmail.com>
3Date: Tue, 24 Nov 2015 16:46:27 +0200
4Subject: [PATCH] introspection.m4: prefix pkgconfig paths with
5 PKG_CONFIG_SYSROOT_DIR
6
7We can't use our tweaked introspection.m4 from gobject-introspection tarball
8because gstreamer also defines INTROSPECTION_INIT in its introspection.m4, which
9is later supplied to g-ir-scanner.
10
11Upstream-Status: Pending [review on oe-core list]
12Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com>
13---
14 common/m4/introspection.m4 | 12 ++++++------
15 1 file changed, 6 insertions(+), 6 deletions(-)
16
17diff --git a/common/m4/introspection.m4 b/common/m4/introspection.m4
18index 162be57..217a6ae 100644
19--- a/common/m4/introspection.m4
20+++ b/common/m4/introspection.m4
21@@ -54,14 +54,14 @@ m4_define([_GOBJECT_INTROSPECTION_CHECK_INTERNAL],
22 INTROSPECTION_GIRDIR=
23 INTROSPECTION_TYPELIBDIR=
24 if test "x$found_introspection" = "xyes"; then
25- INTROSPECTION_SCANNER=`$PKG_CONFIG --variable=g_ir_scanner gobject-introspection-1.0`
26- INTROSPECTION_COMPILER=`$PKG_CONFIG --variable=g_ir_compiler gobject-introspection-1.0`
27- INTROSPECTION_GENERATE=`$PKG_CONFIG --variable=g_ir_generate gobject-introspection-1.0`
28+ INTROSPECTION_SCANNER=$PKG_CONFIG_SYSROOT_DIR`$PKG_CONFIG --variable=g_ir_scanner gobject-introspection-1.0`
29+ INTROSPECTION_COMPILER=$PKG_CONFIG_SYSROOT_DIR`$PKG_CONFIG --variable=g_ir_compiler gobject-introspection-1.0`
30+ INTROSPECTION_GENERATE=$PKG_CONFIG_SYSROOT_DIR`$PKG_CONFIG --variable=g_ir_generate gobject-introspection-1.0`
31 INTROSPECTION_GIRDIR=`$PKG_CONFIG --variable=girdir gobject-introspection-1.0`
32 INTROSPECTION_TYPELIBDIR="$($PKG_CONFIG --variable=typelibdir gobject-introspection-1.0)"
33 INTROSPECTION_CFLAGS=`$PKG_CONFIG --cflags gobject-introspection-1.0`
34 INTROSPECTION_LIBS=`$PKG_CONFIG --libs gobject-introspection-1.0`
35- INTROSPECTION_MAKEFILE=`$PKG_CONFIG --variable=datadir gobject-introspection-1.0`/gobject-introspection-1.0/Makefile.introspection
36+ INTROSPECTION_MAKEFILE=$PKG_CONFIG_SYSROOT_DIR`$PKG_CONFIG --variable=datadir gobject-introspection-1.0`/gobject-introspection-1.0/Makefile.introspection
37 INTROSPECTION_INIT="extern void gst_init(gint*,gchar**); gst_init(NULL,NULL);"
38 fi
39 AC_SUBST(INTROSPECTION_SCANNER)
40--
412.6.2
42
diff --git a/recipes-multimedia/gstreamer/files/gtk-doc-tweaks.patch b/recipes-multimedia/gstreamer/files/gtk-doc-tweaks.patch
deleted file mode 100644
index d86c78d7..00000000
--- a/recipes-multimedia/gstreamer/files/gtk-doc-tweaks.patch
+++ /dev/null
@@ -1,47 +0,0 @@
1From 7018ca1c4bf26c8317e7fcd2e7e4e648195f42ca Mon Sep 17 00:00:00 2001
2From: Ross Burton <ross.burton@intel.com>
3Date: Wed, 20 Dec 2017 13:03:03 +0000
4Subject: [PATCH] gstreamer: use a patch instead of sed to fix gtk-doc
5
6Patch the gtk-doc makefiles so that the qemu wrapper is used to run transient
7binaries instead of libtool wrapper or running them directly.
8
9Also substitute a bogus plugin scanner, as trying to run the real one is causing
10issues during build on x86_64.
11
12Upstream-Status: Inappropriate
13Signed-off-by: Ross Burton <ross.burton@intel.com>
14
15---
16 common/gtk-doc.mak | 5 +++--
17 1 file changed, 3 insertions(+), 2 deletions(-)
18
19diff --git a/common/gtk-doc.mak b/common/gtk-doc.mak
20index 3f83491..e5cb0d1 100644
21--- a/common/gtk-doc.mak
22+++ b/common/gtk-doc.mak
23@@ -6,11 +6,11 @@
24 if GTK_DOC_USE_LIBTOOL
25 GTKDOC_CC = $(LIBTOOL) --tag=CC --mode=compile $(CC) $(INCLUDES) $(GTKDOC_DEPS_CFLAGS) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
26 GTKDOC_LD = $(LIBTOOL) --tag=CC --mode=link $(CC) $(GTKDOC_DEPS_LIBS) $(AM_CFLAGS) $(CFLAGS) $(AM_LDFLAGS) $(LDFLAGS)
27-GTKDOC_RUN = $(LIBTOOL) --mode=execute
28+GTKDOC_RUN = $(top_builddir)/gtkdoc-qemuwrapper
29 else
30 GTKDOC_CC = $(CC) $(INCLUDES) $(GTKDOC_DEPS_CFLAGS) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
31 GTKDOC_LD = $(CC) $(GTKDOC_DEPS_LIBS) $(AM_CFLAGS) $(CFLAGS) $(AM_LDFLAGS) $(LDFLAGS)
32-GTKDOC_RUN =
33+GTKDOC_RUN = $(top_builddir)/gtkdoc-qemuwrapper
34 endif
35
36 # We set GPATH here; this gives us semantics for GNU make
37@@ -101,6 +101,7 @@ scan-build.stamp: $(HFILE_GLOB) $(CFILE_GLOB)
38 GST_PLUGIN_PATH_1_0= \
39 GST_REGISTRY_1_0=doc-registry.xml \
40 $(GTKDOC_EXTRA_ENVIRONMENT) \
41+ GST_PLUGIN_SCANNER_1_0="$(top_builddir)/libs/gst/helpers/gst-plugin-scanner-dummy" \
42 CC="$(GTKDOC_CC)" LD="$(GTKDOC_LD)" RUN="$(GTKDOC_RUN)" \
43 CFLAGS="$(GTKDOC_CFLAGS) $(CFLAGS)" \
44 LDFLAGS="$(GTKDOC_LIBS) $(LDFLAGS)" \
45--
462.15.1
47