summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/linux/linux-qoriq/0001-libtraceevent-Fix-build-with-binutils-2.35.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel/linux/linux-qoriq/0001-libtraceevent-Fix-build-with-binutils-2.35.patch')
-rw-r--r--recipes-kernel/linux/linux-qoriq/0001-libtraceevent-Fix-build-with-binutils-2.35.patch38
1 files changed, 38 insertions, 0 deletions
diff --git a/recipes-kernel/linux/linux-qoriq/0001-libtraceevent-Fix-build-with-binutils-2.35.patch b/recipes-kernel/linux/linux-qoriq/0001-libtraceevent-Fix-build-with-binutils-2.35.patch
new file mode 100644
index 00000000..b1d07fc4
--- /dev/null
+++ b/recipes-kernel/linux/linux-qoriq/0001-libtraceevent-Fix-build-with-binutils-2.35.patch
@@ -0,0 +1,38 @@
1From 39efdd94e314336f4acbac4c07e0f37bdc3bef71 Mon Sep 17 00:00:00 2001
2From: Ben Hutchings <ben@decadent.org.uk>
3Date: Sat, 25 Jul 2020 02:06:23 +0100
4Subject: [PATCH] libtraceevent: Fix build with binutils 2.35
5
6In binutils 2.35, 'nm -D' changed to show symbol versions along with
7symbol names, with the usual @@ separator. When generating
8libtraceevent-dynamic-list we need just the names, so strip off the
9version suffix if present.
10
11Upstream-Status: Backport
12
13Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
14Tested-by: Salvatore Bonaccorso <carnil@debian.org>
15Reviewed-by: Steven Rostedt <rostedt@goodmis.org>
16Cc: linux-trace-devel@vger.kernel.org
17Cc: stable@vger.kernel.org
18Signed-off-by: Arnaldo Carvalho de Melo <acme@redhat.com>
19---
20 tools/lib/traceevent/plugins/Makefile | 2 +-
21 1 file changed, 1 insertion(+), 1 deletion(-)
22
23diff --git a/tools/lib/traceevent/plugins/Makefile b/tools/lib/traceevent/plugins/Makefile
24index 349bb81482ab..680d883efe05 100644
25--- a/tools/lib/traceevent/plugins/Makefile
26+++ b/tools/lib/traceevent/plugins/Makefile
27@@ -197,7 +197,7 @@ define do_generate_dynamic_list_file
28 xargs echo "U w W" | tr 'w ' 'W\n' | sort -u | xargs echo`;\
29 if [ "$$symbol_type" = "U W" ];then \
30 (echo '{'; \
31- $(NM) -u -D $1 | awk 'NF>1 {print "\t"$$2";"}' | sort -u;\
32+ $(NM) -u -D $1 | awk 'NF>1 {sub("@.*", "", $$2); print "\t"$$2";"}' | sort -u;\
33 echo '};'; \
34 ) > $2; \
35 else \
36--
372.17.1
38