summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/linux/linux-qoriq/0001-Makefile-fix-gcc-8-build-error.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel/linux/linux-qoriq/0001-Makefile-fix-gcc-8-build-error.patch')
-rw-r--r--recipes-kernel/linux/linux-qoriq/0001-Makefile-fix-gcc-8-build-error.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/recipes-kernel/linux/linux-qoriq/0001-Makefile-fix-gcc-8-build-error.patch b/recipes-kernel/linux/linux-qoriq/0001-Makefile-fix-gcc-8-build-error.patch
new file mode 100644
index 00000000..b4c4aed8
--- /dev/null
+++ b/recipes-kernel/linux/linux-qoriq/0001-Makefile-fix-gcc-8-build-error.patch
@@ -0,0 +1,25 @@
1From 5066b8f46b0f2348881923491b93825ac04d13d2 Mon Sep 17 00:00:00 2001
2From: Chunrong Guo <chunrong.guo@nxp.com>
3Date: Sat, 29 Sep 2018 14:12:34 +0800
4Subject: [PATCH] Makefile: fix gcc-8 build error
5
6Signed-off-by: BJ DevOps Team <bjdevops@NXP1.onmicrosoft.com>
7---
8 Makefile | 1 +
9 1 file changed, 1 insertion(+)
10
11diff --git a/Makefile b/Makefile
12index 53d57ac..b7c5fd4 100644
13--- a/Makefile
14+++ b/Makefile
15@@ -395,6 +395,7 @@ LINUXINCLUDE += $(filter-out $(LINUXINCLUDE),$(USERINCLUDE))
16 KBUILD_AFLAGS := -D__ASSEMBLY__
17 KBUILD_CFLAGS := -Wall -Wundef -Wstrict-prototypes -Wno-trigraphs \
18 -fno-strict-aliasing -fno-common \
19+ -Wno-packed-not-aligned -Wno-tautological-compare \
20 -Werror-implicit-function-declaration \
21 -Wno-format-security \
22 -std=gnu89
23--
241.8.3.1
25