summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/linux/linux-fslc-imx_6.6.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel/linux/linux-fslc-imx_6.6.bb')
-rw-r--r--recipes-kernel/linux/linux-fslc-imx_6.6.bb22
1 files changed, 13 insertions, 9 deletions
diff --git a/recipes-kernel/linux/linux-fslc-imx_6.6.bb b/recipes-kernel/linux/linux-fslc-imx_6.6.bb
index 4810ca11..7bf04fce 100644
--- a/recipes-kernel/linux/linux-fslc-imx_6.6.bb
+++ b/recipes-kernel/linux/linux-fslc-imx_6.6.bb
@@ -28,20 +28,24 @@ Latest stable Kernel patchlevel is applied and maintained by Community."
28# ------------------------------------------------------------------------------ 28# ------------------------------------------------------------------------------
29# 1. Stable (tag or SHA(s)) 29# 1. Stable (tag or SHA(s))
30# ------------------------------------------------------------------------------ 30# ------------------------------------------------------------------------------
31# tag: v6.6.23 31# tag: v6.6.51
32# 32#
33# ------------------------------------------------------------------------------ 33# ------------------------------------------------------------------------------
34# 2. NXP-specific (tag or SHA(s)) 34# 2. NXP-specific (tag or SHA(s))
35# ------------------------------------------------------------------------------ 35# ------------------------------------------------------------------------------
36# tag: lf-6.6.3-1.0.00 36# tag: lf-6.6.23-2.0.0
37# 37#
38# ------------------------------------------------------------------------------ 38# ------------------------------------------------------------------------------
39# 3. Critical patches (SHA(s)) 39# 3. Critical patches (SHA(s))
40# ------------------------------------------------------------------------------ 40# ------------------------------------------------------------------------------
41# - f67cb9a5b4fb7 Revert "net: stmmac: fix FPE events losing" 41
42# - 1918c2eb8b07f Revert "dmaengine: fsl-edma: fix DMA channel leak in eDMAv4" 42# $ git log --oneline --no-merges v6.6.34.. ^mainline/linux-6.6.y ^NXP/lf-6.6.y
43# - 42289407ee38f Revert "dmaengine: fsl-edma: Add judgment on enabling round robin arbitration" 43# - a10c64e35a24 tty: vt: conmakehash: cope with abs_srctree no longer in env
44# - 952f79923f055 Revert "dmaengine: fsl-edma: Do not suspend and resume the masked dma channel when the system is sleeping" 44# - 3fb57e773e55 tty: vt: conmakehash: Don't mention the full path of the input in output
45# - d1198b88bc1b Revert "dmaengine: fsl-edma: add address for channel mux register in fsl_edma_chan"
46# - 717fee4a9cf7 Revert "dmaengine: fsl-edma: add i.MX8ULP edma support"
47# - 74ef72069927 Revert "dmaengine: fsl-edma: clean up unused "fsl,imx8qm-adma" compatible string"
48# - b54c6ea17058 Revert "dmaengine: fsl-edma: change the memory access from local into remote mode in i.MX 8QM"
45# 49#
46# NOTE to upgraders: 50# NOTE to upgraders:
47# This recipe should NOT collect individual patches, they should be applied to 51# This recipe should NOT collect individual patches, they should be applied to
@@ -51,16 +55,16 @@ Latest stable Kernel patchlevel is applied and maintained by Community."
51 55
52require linux-imx.inc 56require linux-imx.inc
53 57
54KBRANCH = "6.6-2.0.x-imx" 58KBRANCH = "6.6-2.1.x-imx"
55SRC_URI = "git://github.com/Freescale/linux-fslc.git;branch=${KBRANCH};protocol=https" 59SRC_URI = "git://github.com/Freescale/linux-fslc.git;branch=${KBRANCH};protocol=https"
56SRCREV = "dd280fd310dd5fabbff7393175ee9d7a6aea6b34" 60SRCREV = "ea326ecb9fc05493c53e51832e447c157268e2ab"
57 61
58# PV is defined in the base in linux-imx.inc file and uses the LINUX_VERSION definition 62# PV is defined in the base in linux-imx.inc file and uses the LINUX_VERSION definition
59# required by kernel-yocto.bbclass. 63# required by kernel-yocto.bbclass.
60# 64#
61# LINUX_VERSION define should match to the kernel version referenced by SRC_URI and 65# LINUX_VERSION define should match to the kernel version referenced by SRC_URI and
62# should be updated once patchlevel is merged. 66# should be updated once patchlevel is merged.
63LINUX_VERSION = "6.6.23" 67LINUX_VERSION = "6.6.54"
64 68
65KBUILD_DEFCONFIG:mx6-generic-bsp = "imx_v7_defconfig" 69KBUILD_DEFCONFIG:mx6-generic-bsp = "imx_v7_defconfig"
66KBUILD_DEFCONFIG:mx7-generic-bsp = "imx_v7_defconfig" 70KBUILD_DEFCONFIG:mx7-generic-bsp = "imx_v7_defconfig"