summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/linux/linux-fslc-imx-rt_4.1-2.0.x.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel/linux/linux-fslc-imx-rt_4.1-2.0.x.bb')
-rw-r--r--recipes-kernel/linux/linux-fslc-imx-rt_4.1-2.0.x.bb7
1 files changed, 1 insertions, 6 deletions
diff --git a/recipes-kernel/linux/linux-fslc-imx-rt_4.1-2.0.x.bb b/recipes-kernel/linux/linux-fslc-imx-rt_4.1-2.0.x.bb
index fbb32d81..10610a5a 100644
--- a/recipes-kernel/linux/linux-fslc-imx-rt_4.1-2.0.x.bb
+++ b/recipes-kernel/linux/linux-fslc-imx-rt_4.1-2.0.x.bb
@@ -16,16 +16,11 @@ SRC_URI += " \
16 file://0001-fix-build.patch \ 16 file://0001-fix-build.patch \
17 file://0002-no-split-ptlocks.patch \ 17 file://0002-no-split-ptlocks.patch \
18 file://0003-Work-around-CPU-stalls-in-the-imx-sdma-driver.patch \ 18 file://0003-Work-around-CPU-stalls-in-the-imx-sdma-driver.patch \
19 file://0004-export-swait-locked-functions.patch \
19" 20"
20 21
21SRC_URI[rt-patch.md5sum] = "6dd1193203cdf6a1a4758fc8baf07a4a" 22SRC_URI[rt-patch.md5sum] = "6dd1193203cdf6a1a4758fc8baf07a4a"
22SRC_URI[rt-patch.sha256sum] = "427e736022e59f83c9489eda889559fcd4fe4abb5646570ade32f2128f2fa725" 23SRC_URI[rt-patch.sha256sum] = "427e736022e59f83c9489eda889559fcd4fe4abb5646570ade32f2128f2fa725"
23 24
24python () {
25 using_builtin_driver = (d.getVar("MACHINE_USES_VIVANTE_KERNEL_DRIVER_MODULE", True) or "") != "1"
26 if not using_builtin_driver:
27 raise bb.parse.SkipPackage('You must use the builtin driver with the Linux RT patch as the external module does not yet include support for it. Set "MACHINE_USES_VIVANTE_KERNEL_DRIVER_MODULE" accordingly.')
28}
29
30 25
31COMPATIBLE_MACHINE = "(mx6|mx7)" 26COMPATIBLE_MACHINE = "(mx6|mx7)"