summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/kernel-modules/kernel-module-isp-vvcam_4.2.2.21.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel/kernel-modules/kernel-module-isp-vvcam_4.2.2.21.0.bb')
-rw-r--r--recipes-kernel/kernel-modules/kernel-module-isp-vvcam_4.2.2.21.0.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/recipes-kernel/kernel-modules/kernel-module-isp-vvcam_4.2.2.21.0.bb b/recipes-kernel/kernel-modules/kernel-module-isp-vvcam_4.2.2.21.0.bb
new file mode 100644
index 00000000..206018eb
--- /dev/null
+++ b/recipes-kernel/kernel-modules/kernel-module-isp-vvcam_4.2.2.21.0.bb
@@ -0,0 +1,20 @@
1# Copyright 2020-2022 NXP
2
3DESCRIPTION = "Kernel loadable module for ISP"
4LICENSE = "GPL-2.0-only"
5LIC_FILES_CHKSUM = "file://${S}/../LICENSE;md5=64381a6ea83b48c39fe524c85f65fb44"
6
7SRC_URI = "${ISP_KERNEL_SRC};branch=${SRCBRANCH}"
8ISP_KERNEL_SRC ?= "git://github.com/nxp-imx/isp-vvcam.git;protocol=https"
9SRCBRANCH = "lf-6.1.y_1.0.0"
10SRCREV = "774808215a15e2acdc02967907c47515e3512f2d"
11
12S = "${WORKDIR}/git/vvcam/v4l2"
13
14inherit module
15
16DEBUG_PREFIX_MAP:prepend = " \
17 -fmacro-prefix-map=${WORKDIR}/git/vvcam=/usr/src/debug/${PN}/${EXTENDPE}${PV}-${PR} \
18 -fdebug-prefix-map=${WORKDIR}/git/vvcam=/usr/src/debug/${PN}/${EXTENDPE}${PV}-${PR} "
19
20COMPATIBLE_MACHINE = "(mx8mp-nxp-bsp)"