summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv_6.4.3.p4.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv_6.4.3.p4.4.bb')
-rw-r--r--recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv_6.4.3.p4.4.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv_6.4.3.p4.4.bb b/recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv_6.4.3.p4.4.bb
new file mode 100644
index 00000000..6c270dfb
--- /dev/null
+++ b/recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv_6.4.3.p4.4.bb
@@ -0,0 +1,24 @@
1# Copyright (C) 2015-2016 Freescale Semiconductor
2# Copyright (C) 2017-2021 NXP
3
4SUMMARY = "Kernel loadable module for Vivante GPU"
5DESCRIPTION = "Builds the Vivante GPU kernel driver as a loadable kernel module, \
6allowing flexibility to use a newer graphics release with an older kernel."
7LICENSE = "GPL-2.0-only"
8LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0-only;md5=801f80980d171dd6425610833a22dbe6"
9
10SRC_URI = "${KERNEL_SRC};subpath=drivers/mxc/gpu-viv;destsuffix=git/src \
11 file://Add-makefile.patch"
12KERNEL_SRC ?= "git://github.com/nxp-imx/linux-imx.git;protocol=https;branch=${SRCBRANCH}"
13SRCBRANCH = "lf-5.15.y"
14LOCALVERSION = "-5.15.52-2.1.0"
15SRCREV = "36363d8623ba60858e2632b7d2b70dae932c9a8b"
16
17S = "${WORKDIR}/git"
18
19inherit module
20
21EXTRA_OEMAKE += "CONFIG_MXC_GPU_VIV=m"
22
23KERNEL_MODULE_AUTOLOAD = "galcore"
24COMPATIBLE_MACHINE = "(imx-nxp-bsp)"