summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/cryptodev/sdk_patches/0067-fix-issues-with-install-target.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel/cryptodev/sdk_patches/0067-fix-issues-with-install-target.patch')
-rw-r--r--recipes-kernel/cryptodev/sdk_patches/0067-fix-issues-with-install-target.patch52
1 files changed, 0 insertions, 52 deletions
diff --git a/recipes-kernel/cryptodev/sdk_patches/0067-fix-issues-with-install-target.patch b/recipes-kernel/cryptodev/sdk_patches/0067-fix-issues-with-install-target.patch
deleted file mode 100644
index e60e90a9..00000000
--- a/recipes-kernel/cryptodev/sdk_patches/0067-fix-issues-with-install-target.patch
+++ /dev/null
@@ -1,52 +0,0 @@
1From bd36f9cda9fb5eeebec23cc966a81e93b4fa8bf7 Mon Sep 17 00:00:00 2001
2From: Cristian Stoica <cristian.stoica@nxp.com>
3Date: Wed, 26 Oct 2016 12:53:11 +0300
4Subject: [PATCH 067/104] fix issues with install target
5
6Aparently, on some setups, 'sudo make' will clear the $PWD variable
7on the first Makefile expansion. This leads to failures of "sudo make
8install" or other issues when trying to preserve the environment with
9sudo -E.
10
11There are two solutions to this problem:
121) Use $$PWD instead of $(PWD) to render `$PWD` as the actual string to
13be used on the secondary Makefile expansion.
14This is used (albeit inconsistently) in the Linux kernel guide for
15external modules:
16kernel https://www.kernel.org/doc/Documentation/kbuild/modules.txt
17
182) A second solution is based on GNU make which sets CURDIR to the
19pathname of current working directory. This variable is never touched
20again by make.
21This solution is choosen for it is just as clear as the PWD one would
22have been had it worked in the first place.
23
24Signed-off-by: Cristian Stoica <cristian.stoica@nxp.com>
25
26
27
28--- a/Makefileold 2017-04-18 13:55:30.740561749 +0800
29+++ b/Makefile 2017-04-18 13:58:04.348556431 +0800
30@@ -15,7 +15,7 @@
31
32 obj-m += cryptodev.o
33
34-KERNEL_MAKE_OPTS := -C $(KERNEL_DIR) M=$(PWD)
35+KERNEL_MAKE_OPTS := -C $(KERNEL_DIR) M=$(CURDIR)
36 ifneq ($(ARCH),)
37 KERNEL_MAKE_OPTS += ARCH=$(ARCH)
38 endif
39@@ -32,11 +32,11 @@
40 install: modules_install
41
42 modules_install:
43- $(MAKE) -C $(KERNEL_DIR) M=$(PWD) modules_install
44+ $(MAKE) $(KERNEL_MAKE_OPTS) modules_install
45 install -m 644 -D crypto/cryptodev.h $(DESTDIR)/$(includedir)/crypto/cryptodev.h
46
47 clean:
48- $(MAKE) -C $(KERNEL_DIR) M=$(PWD) clean
49+ $(MAKE) $(KERNEL_MAKE_OPTS) clean
50 rm -f $(hostprogs) *~
51 CFLAGS=$(CRYPTODEV_CFLAGS) KERNEL_DIR=$(KERNEL_DIR) $(MAKE) -C tests clean
52