summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/cryptodev/cryptodev-tests_1.7.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel/cryptodev/cryptodev-tests_1.7.bb')
-rw-r--r--recipes-kernel/cryptodev/cryptodev-tests_1.7.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/recipes-kernel/cryptodev/cryptodev-tests_1.7.bb b/recipes-kernel/cryptodev/cryptodev-tests_1.7.bb
new file mode 100644
index 00000000..128ccc99
--- /dev/null
+++ b/recipes-kernel/cryptodev/cryptodev-tests_1.7.bb
@@ -0,0 +1,17 @@
1require cryptodev_${PV}.inc
2
3SUMMARY = "A test suite for /dev/crypto device driver"
4DEPENDS = "openssl"
5
6EXTRA_OEMAKE='KERNEL_DIR="${STAGING_KERNEL_DIR}" PREFIX="${D}"'
7
8do_compile() {
9 oe_runmake testprogs
10}
11
12do_install() {
13 oe_runmake install_tests
14}
15
16FILES_${PN}-dbg += "${bindir}/tests_cryptodev/.debug"
17FILES_${PN} = "${bindir}/tests_cryptodev/*"