summaryrefslogtreecommitdiffstats
path: root/recipes-graphics
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-graphics')
-rw-r--r--recipes-graphics/imx-gpu-viv/imx-gpu-viv.inc10
-rw-r--r--recipes-graphics/imx-gpu-viv/imx-gpu-viv_5.0.11.p8.3-hfp.bb2
2 files changed, 0 insertions, 12 deletions
diff --git a/recipes-graphics/imx-gpu-viv/imx-gpu-viv.inc b/recipes-graphics/imx-gpu-viv/imx-gpu-viv.inc
index 4d770812..ce00724b 100644
--- a/recipes-graphics/imx-gpu-viv/imx-gpu-viv.inc
+++ b/recipes-graphics/imx-gpu-viv/imx-gpu-viv.inc
@@ -51,16 +51,6 @@ python __anonymous () {
51 has_vivante_kernel_driver_support = (d.getVar('MACHINE_HAS_VIVANTE_KERNEL_DRIVER_SUPPORT', True) or '0') 51 has_vivante_kernel_driver_support = (d.getVar('MACHINE_HAS_VIVANTE_KERNEL_DRIVER_SUPPORT', True) or '0')
52 if has_vivante_kernel_driver_support != '1': 52 if has_vivante_kernel_driver_support != '1':
53 raise bb.parse.SkipPackage('The kernel of machine needs to have Vivante kernel driver support for this recipe to be used.') 53 raise bb.parse.SkipPackage('The kernel of machine needs to have Vivante kernel driver support for this recipe to be used.')
54
55 # Skip package if it does not match the machine float-point type in use
56 is_machine_hardfp = base_contains("TUNE_FEATURES", "callconvention-hard", True, False, d)
57 is_package_hardfp = d.getVar("PACKAGE_FP_TYPE", True) == "hardfp"
58
59 if is_package_hardfp != is_machine_hardfp:
60 PN = d.getVar("PN", True)
61 PV = d.getVar("PV", True)
62 bb.debug(1, "Skipping %s (%s) as machine and package float-point does not match" % (PN, PV))
63 raise bb.parse.SkipPackage("Package Float-Point is not compatible with the machine")
64} 54}
65 55
66USE_X11 = "${@base_contains("DISTRO_FEATURES", "x11", "yes", "no", d)}" 56USE_X11 = "${@base_contains("DISTRO_FEATURES", "x11", "yes", "no", d)}"
diff --git a/recipes-graphics/imx-gpu-viv/imx-gpu-viv_5.0.11.p8.3-hfp.bb b/recipes-graphics/imx-gpu-viv/imx-gpu-viv_5.0.11.p8.3-hfp.bb
index 319f8852..d3258576 100644
--- a/recipes-graphics/imx-gpu-viv/imx-gpu-viv_5.0.11.p8.3-hfp.bb
+++ b/recipes-graphics/imx-gpu-viv/imx-gpu-viv_5.0.11.p8.3-hfp.bb
@@ -5,5 +5,3 @@ require imx-gpu-viv.inc
5 5
6SRC_URI[md5sum] = "0416a2a02bfaed6d5337428375d568d5" 6SRC_URI[md5sum] = "0416a2a02bfaed6d5337428375d568d5"
7SRC_URI[sha256sum] = "0400f19dce7223e046ca693cae8578201904c8e7bdcf0c444a6114afa14f09fe" 7SRC_URI[sha256sum] = "0400f19dce7223e046ca693cae8578201904c8e7bdcf0c444a6114afa14f09fe"
8
9PACKAGE_FP_TYPE = "hardfp"