summaryrefslogtreecommitdiffstats
path: root/recipes-graphics
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-graphics')
-rw-r--r--recipes-graphics/mesa/mesa-etnaviv-env/mesa-etnaviv.conf3
-rw-r--r--recipes-graphics/mesa/mesa-etnaviv-env_0.1.bb24
2 files changed, 27 insertions, 0 deletions
diff --git a/recipes-graphics/mesa/mesa-etnaviv-env/mesa-etnaviv.conf b/recipes-graphics/mesa/mesa-etnaviv-env/mesa-etnaviv.conf
new file mode 100644
index 00000000..db4f8740
--- /dev/null
+++ b/recipes-graphics/mesa/mesa-etnaviv-env/mesa-etnaviv.conf
@@ -0,0 +1,3 @@
1[Manager]
2DefaultEnvironment=MESA_GL_VERSION_OVERRIDE=2.1 ETNA_MESA_DEBUG=nir
3
diff --git a/recipes-graphics/mesa/mesa-etnaviv-env_0.1.bb b/recipes-graphics/mesa/mesa-etnaviv-env_0.1.bb
new file mode 100644
index 00000000..13cdf02d
--- /dev/null
+++ b/recipes-graphics/mesa/mesa-etnaviv-env_0.1.bb
@@ -0,0 +1,24 @@
1SUMMARY = "Mesa environment variables for etnaviv on xserver"
2LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
4
5PACKAGE_ARCH = "${MACHINE_ARCH}"
6
7SRC_URI = "file://mesa-etnaviv.conf"
8
9do_configure[noexec] = "1"
10do_compile[noexec] = "1"
11
12do_install() {
13 # MESA global envirronment variables
14
15 # systemd
16 if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
17 install -D -m 644 ${WORKDIR}/mesa-etnaviv.conf \
18 ${D}${sysconfdir}/systemd/system.conf.d/mesa-etnaviv.conf
19 fi
20
21 # sysvinit - TODO
22}
23
24ALLOW_EMPTY_${PN} = "1"