summaryrefslogtreecommitdiffstats
path: root/recipes-graphics
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-graphics')
-rw-r--r--recipes-graphics/imx-gpu-viv/imx-gpu-viv-6.inc2
-rw-r--r--recipes-graphics/mesa/mesa-etnaviv-env_0.1.bb4
-rw-r--r--recipes-graphics/wayland/weston-init.bbappend4
-rw-r--r--recipes-graphics/wayland/weston_10.0.5.imx.bb8
-rw-r--r--recipes-graphics/wayland/weston_12.0.3.imx.bb8
5 files changed, 13 insertions, 13 deletions
diff --git a/recipes-graphics/imx-gpu-viv/imx-gpu-viv-6.inc b/recipes-graphics/imx-gpu-viv/imx-gpu-viv-6.inc
index e33df444..2d02d7ab 100644
--- a/recipes-graphics/imx-gpu-viv/imx-gpu-viv-6.inc
+++ b/recipes-graphics/imx-gpu-viv/imx-gpu-viv-6.inc
@@ -274,7 +274,7 @@ do_install () {
274 rm -rf ${D}$f 274 rm -rf ${D}$f
275 done 275 done
276 else 276 else
277 install -Dm 0644 ${WORKDIR}/imx_icd.json ${D}${sysconfdir}/vulkan/icd.d/imx_icd.json 277 install -Dm 0644 ${UNPACKDIR}/imx_icd.json ${D}${sysconfdir}/vulkan/icd.d/imx_icd.json
278 sed -i "s,%libdir%,${libdir}," ${D}${sysconfdir}/vulkan/icd.d/imx_icd.json 278 sed -i "s,%libdir%,${libdir}," ${D}${sysconfdir}/vulkan/icd.d/imx_icd.json
279 sed -i "s,%api_version%,${LIBVULKAN_API_VERSION}," ${D}${sysconfdir}/vulkan/icd.d/imx_icd.json 279 sed -i "s,%api_version%,${LIBVULKAN_API_VERSION}," ${D}${sysconfdir}/vulkan/icd.d/imx_icd.json
280 fi 280 fi
diff --git a/recipes-graphics/mesa/mesa-etnaviv-env_0.1.bb b/recipes-graphics/mesa/mesa-etnaviv-env_0.1.bb
index 87d05365..658b28de 100644
--- a/recipes-graphics/mesa/mesa-etnaviv-env_0.1.bb
+++ b/recipes-graphics/mesa/mesa-etnaviv-env_0.1.bb
@@ -17,13 +17,13 @@ do_install:use-mainline-bsp() {
17 17
18 # systemd 18 # systemd
19 if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then 19 if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
20 install -D -m 644 ${WORKDIR}/mesa-etnaviv.conf \ 20 install -D -m 644 ${UNPACKDIR}/mesa-etnaviv.conf \
21 ${D}${sysconfdir}/systemd/system.conf.d/mesa-etnaviv.conf 21 ${D}${sysconfdir}/systemd/system.conf.d/mesa-etnaviv.conf
22 fi 22 fi
23 23
24 # sysvinit 24 # sysvinit
25 if ${@bb.utils.contains('DISTRO_FEATURES', 'sysvinit', 'true', 'false', d)}; then 25 if ${@bb.utils.contains('DISTRO_FEATURES', 'sysvinit', 'true', 'false', d)}; then
26 install -D -m 644 ${WORKDIR}/mesa-etnaviv.sh \ 26 install -D -m 644 ${UNPACKDIR}/mesa-etnaviv.sh \
27 ${D}${sysconfdir}/profile.d/mesa-etnaviv.sh 27 ${D}${sysconfdir}/profile.d/mesa-etnaviv.sh
28 fi 28 fi
29} 29}
diff --git a/recipes-graphics/wayland/weston-init.bbappend b/recipes-graphics/wayland/weston-init.bbappend
index 9d04df23..07a4ea86 100644
--- a/recipes-graphics/wayland/weston-init.bbappend
+++ b/recipes-graphics/wayland/weston-init.bbappend
@@ -58,8 +58,8 @@ PACKAGECONFIG[use-g2d] = ",,"
58PACKAGECONFIG[xwayland] = ",," 58PACKAGECONFIG[xwayland] = ",,"
59 59
60do_install:append() { 60do_install:append() {
61 if [ -f "${WORKDIR}/weston.config" ]; then 61 if [ -f "${UNPACKDIR}/weston.config" ]; then
62 install -Dm0755 ${WORKDIR}/weston.config ${D}${sysconfdir}/default/weston 62 install -Dm0755 ${UNPACKDIR}/weston.config ${D}${sysconfdir}/default/weston
63 fi 63 fi
64 64
65 if [ "${@bb.utils.contains('PACKAGECONFIG', 'gbm-format', 'yes', 'no', d)}" = "yes" ]; then 65 if [ "${@bb.utils.contains('PACKAGECONFIG', 'gbm-format', 'yes', 'no', d)}" = "yes" ]; then
diff --git a/recipes-graphics/wayland/weston_10.0.5.imx.bb b/recipes-graphics/wayland/weston_10.0.5.imx.bb
index 99624887..df2898f0 100644
--- a/recipes-graphics/wayland/weston_10.0.5.imx.bb
+++ b/recipes-graphics/wayland/weston_10.0.5.imx.bb
@@ -109,18 +109,18 @@ do_install:append() {
109 # If X11, ship a desktop file to launch it 109 # If X11, ship a desktop file to launch it
110 if [ "${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)}" ]; then 110 if [ "${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)}" ]; then
111 install -d ${D}${datadir}/applications 111 install -d ${D}${datadir}/applications
112 install ${WORKDIR}/weston.desktop ${D}${datadir}/applications 112 install ${UNPACKDIR}/weston.desktop ${D}${datadir}/applications
113 113
114 install -d ${D}${datadir}/icons/hicolor/48x48/apps 114 install -d ${D}${datadir}/icons/hicolor/48x48/apps
115 install ${WORKDIR}/weston.png ${D}${datadir}/icons/hicolor/48x48/apps 115 install ${UNPACKDIR}/weston.png ${D}${datadir}/icons/hicolor/48x48/apps
116 fi 116 fi
117 117
118 if [ "${@bb.utils.contains('PACKAGECONFIG', 'xwayland', 'yes', 'no', d)}" = "yes" ]; then 118 if [ "${@bb.utils.contains('PACKAGECONFIG', 'xwayland', 'yes', 'no', d)}" = "yes" ]; then
119 install -Dm 644 ${WORKDIR}/xwayland.weston-start ${D}${datadir}/weston-start/xwayland 119 install -Dm 644 ${UNPACKDIR}/xwayland.weston-start ${D}${datadir}/weston-start/xwayland
120 fi 120 fi
121 121
122 if [ "${@bb.utils.contains('PACKAGECONFIG', 'systemd', 'yes', 'no', d)}" = "yes" ]; then 122 if [ "${@bb.utils.contains('PACKAGECONFIG', 'systemd', 'yes', 'no', d)}" = "yes" ]; then
123 install -Dm 644 ${WORKDIR}/systemd-notify.weston-start ${D}${datadir}/weston-start/systemd-notify 123 install -Dm 644 ${UNPACKDIR}/systemd-notify.weston-start ${D}${datadir}/weston-start/systemd-notify
124 fi 124 fi
125 125
126 if [ "${@bb.utils.contains('PACKAGECONFIG', 'launch', 'yes', 'no', d)}" = "yes" ]; then 126 if [ "${@bb.utils.contains('PACKAGECONFIG', 'launch', 'yes', 'no', d)}" = "yes" ]; then
diff --git a/recipes-graphics/wayland/weston_12.0.3.imx.bb b/recipes-graphics/wayland/weston_12.0.3.imx.bb
index 8114ddbb..14b79f18 100644
--- a/recipes-graphics/wayland/weston_12.0.3.imx.bb
+++ b/recipes-graphics/wayland/weston_12.0.3.imx.bb
@@ -116,18 +116,18 @@ do_install:append() {
116 # If X11, ship a desktop file to launch it 116 # If X11, ship a desktop file to launch it
117 if [ "${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)}" ]; then 117 if [ "${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)}" ]; then
118 install -d ${D}${datadir}/applications 118 install -d ${D}${datadir}/applications
119 install ${WORKDIR}/weston.desktop ${D}${datadir}/applications 119 install ${UNPACKDIR}/weston.desktop ${D}${datadir}/applications
120 120
121 install -d ${D}${datadir}/icons/hicolor/48x48/apps 121 install -d ${D}${datadir}/icons/hicolor/48x48/apps
122 install ${WORKDIR}/weston.png ${D}${datadir}/icons/hicolor/48x48/apps 122 install ${UNPACKDIR}/weston.png ${D}${datadir}/icons/hicolor/48x48/apps
123 fi 123 fi
124 124
125 if [ "${@bb.utils.contains('PACKAGECONFIG', 'xwayland', 'yes', 'no', d)}" = "yes" ]; then 125 if [ "${@bb.utils.contains('PACKAGECONFIG', 'xwayland', 'yes', 'no', d)}" = "yes" ]; then
126 install -Dm 644 ${WORKDIR}/xwayland.weston-start ${D}${datadir}/weston-start/xwayland 126 install -Dm 644 ${UNPACKDIR}/xwayland.weston-start ${D}${datadir}/weston-start/xwayland
127 fi 127 fi
128 128
129 if [ "${@bb.utils.contains('PACKAGECONFIG', 'systemd', 'yes', 'no', d)}" = "yes" ]; then 129 if [ "${@bb.utils.contains('PACKAGECONFIG', 'systemd', 'yes', 'no', d)}" = "yes" ]; then
130 install -Dm 644 ${WORKDIR}/systemd-notify.weston-start ${D}${datadir}/weston-start/systemd-notify 130 install -Dm 644 ${UNPACKDIR}/systemd-notify.weston-start ${D}${datadir}/weston-start/systemd-notify
131 fi 131 fi
132 132
133 if [ "${@bb.utils.contains('PACKAGECONFIG', 'launch', 'yes', 'no', d)}" = "yes" ]; then 133 if [ "${@bb.utils.contains('PACKAGECONFIG', 'launch', 'yes', 'no', d)}" = "yes" ]; then