summaryrefslogtreecommitdiffstats
path: root/recipes-graphics/wayland/weston_1.11.1.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-graphics/wayland/weston_1.11.1.bbappend')
-rw-r--r--recipes-graphics/wayland/weston_1.11.1.bbappend46
1 files changed, 0 insertions, 46 deletions
diff --git a/recipes-graphics/wayland/weston_1.11.1.bbappend b/recipes-graphics/wayland/weston_1.11.1.bbappend
deleted file mode 100644
index ccbf393a..00000000
--- a/recipes-graphics/wayland/weston_1.11.1.bbappend
+++ /dev/null
@@ -1,46 +0,0 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2
3SRC_URI_append_imxgpu3d = " \
4 file://0001-MGS-2352-ccc-Add-GPU-VIV-support-for-weston-1.11.patch \
5 file://0002-MGS-2521-ccc-Enable-g2d-renderer-for-weston-1.11.patch \
6 file://0003-MGS-1783-xwld-Add-clone-mode-support-for-multi-displ.patch \
7 file://0004-MGS-1668-xwld-System-can-not-boot-up-to-desktop.patch \
8 file://0005-MGS-1724-xwld-G2D-compositor-build-failed-in-slevk-b.patch \
9 file://0006-Link-compositor-to-egl.patch \
10"
11
12SRC_URI_append = " \
13 file://0007-xwayland-Fix-crash-when-run-with-no-input-device.patch \
14"
15
16# The 'egl' configuration of weston requires gles support, and consideration
17# must be taken for the different SoC capabilities:
18# - For SoCs with 3d support, imx-gpu-viv provides hardware-accelerated
19# egl and gles, so weston egl configuration is enabled.
20# - For SoCs with VG2D, like i.MX 6SoloLite, imx-gpu-viv provides
21# hardware-accelerated egl but does not provide a compatible software
22# version of gles, so weston egl configuration is disabled.
23# - For SoCs with no GPU, mesa provides software implementations of egl
24# and gles, so weston egl configuration is enabled.
25PACKAGECONFIG_IMX_TO_APPEND = ""
26PACKAGECONFIG_IMX_TO_APPEND_imxgpu3d = "cairo-glesv2"
27PACKAGECONFIG_IMX_TO_REMOVE = ""
28PACKAGECONFIG_IMX_TO_REMOVE_imxgpu2d = "egl"
29PACKAGECONFIG_IMX_TO_REMOVE_imxgpu3d = ""
30
31PACKAGECONFIG_append = " ${PACKAGECONFIG_IMX_TO_APPEND}"
32PACKAGECONFIG_remove = " ${PACKAGECONFIG_IMX_TO_REMOVE}"
33
34
35EXTRA_OECONF_IMX_COMMON = " \
36 --disable-libunwind \
37 --disable-xwayland-test \
38 WESTON_NATIVE_BACKEND=fbdev-backend.so \
39"
40EXTRA_OECONF_IMX = ""
41EXTRA_OECONF_IMX_imxpxp = "${EXTRA_OECONF_IMX_COMMON}"
42EXTRA_OECONF_IMX_imxgpu2d = "${EXTRA_OECONF_IMX_COMMON}"
43
44EXTRA_OECONF_append = " ${EXTRA_OECONF_IMX}"
45
46PACKAGE_ARCH = "${MACHINE_SOCARCH}"