summaryrefslogtreecommitdiffstats
path: root/recipes-graphics/wayland/weston
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-graphics/wayland/weston')
-rw-r--r--recipes-graphics/wayland/weston/0001-Revert-protocol-no-found-wayland-scanner-with-Yocto-.patch8
-rw-r--r--recipes-graphics/wayland/weston/0001-g2d-renderer.c-Include-sys-stat.h.patch34
-rw-r--r--recipes-graphics/wayland/weston/0001-tests-Add-dependency-on-screenshooter-client-protoco.patch33
-rw-r--r--recipes-graphics/wayland/weston/xwayland.weston-start3
4 files changed, 6 insertions, 72 deletions
diff --git a/recipes-graphics/wayland/weston/0001-Revert-protocol-no-found-wayland-scanner-with-Yocto-.patch b/recipes-graphics/wayland/weston/0001-Revert-protocol-no-found-wayland-scanner-with-Yocto-.patch
index 676d0338..39439ce1 100644
--- a/recipes-graphics/wayland/weston/0001-Revert-protocol-no-found-wayland-scanner-with-Yocto-.patch
+++ b/recipes-graphics/wayland/weston/0001-Revert-protocol-no-found-wayland-scanner-with-Yocto-.patch
@@ -1,4 +1,4 @@
1From 77eba6f6b04ff21b77c41500657495b4fd12a5f6 Mon Sep 17 00:00:00 2001 1From 3aa4024ac4107e68552be4dfe5fce511900629c9 Mon Sep 17 00:00:00 2001
2From: Max Krummenacher <max.krummenacher@toradex.com> 2From: Max Krummenacher <max.krummenacher@toradex.com>
3Date: Mon, 11 Jul 2022 19:38:19 +0000 3Date: Mon, 11 Jul 2022 19:38:19 +0000
4Subject: [PATCH] Revert "protocol: no found wayland-scanner with Yocto 4Subject: [PATCH] Revert "protocol: no found wayland-scanner with Yocto
@@ -26,7 +26,7 @@ Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
26 1 file changed, 1 insertion(+), 1 deletion(-) 26 1 file changed, 1 insertion(+), 1 deletion(-)
27 27
28diff --git a/protocol/meson.build b/protocol/meson.build 28diff --git a/protocol/meson.build b/protocol/meson.build
29index bdd322ac..e50b23bb 100644 29index e8698530..ba52089b 100644
30--- a/protocol/meson.build 30--- a/protocol/meson.build
31+++ b/protocol/meson.build 31+++ b/protocol/meson.build
32@@ -1,4 +1,4 @@ 32@@ -1,4 +1,4 @@
@@ -34,7 +34,7 @@ index bdd322ac..e50b23bb 100644
34+dep_scanner = dependency('wayland-scanner', native: true) 34+dep_scanner = dependency('wayland-scanner', native: true)
35 prog_scanner = find_program(dep_scanner.get_pkgconfig_variable('wayland_scanner')) 35 prog_scanner = find_program(dep_scanner.get_pkgconfig_variable('wayland_scanner'))
36 36
37 dep_wp = dependency('wayland-protocols', version: '>= 1.24') 37 dep_wp = dependency('wayland-protocols', version: '>= 1.26',
38-- 38--
392.17.1 392.25.1
40 40
diff --git a/recipes-graphics/wayland/weston/0001-g2d-renderer.c-Include-sys-stat.h.patch b/recipes-graphics/wayland/weston/0001-g2d-renderer.c-Include-sys-stat.h.patch
deleted file mode 100644
index b9cb31fb..00000000
--- a/recipes-graphics/wayland/weston/0001-g2d-renderer.c-Include-sys-stat.h.patch
+++ /dev/null
@@ -1,34 +0,0 @@
1From 4afe9b2f9ef24ce0c9bf1cd41f94ca45afa4f445 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Mon, 12 Sep 2022 20:58:14 -0700
4Subject: [PATCH] g2d-renderer.c: Include sys/stat.h
5
6This is needed for getting stat() prototype, its flagged with clang-15
7as error.
8
9| ../git/libweston/renderer-g2d/g2d-renderer.c:2057:6: error: call to undeclared function 'stat'; ISO C99 and later do not support implicit function declarations [-Wimplicit-function-declaration]
10| if (stat(gr->drm_device, &dev_stat) != 0) {
11| ^
12| 1 error generated.
13
14Upstream-Status: Pending
15Signed-off-by: Khem Raj <raj.khem@gmail.com>
16---
17 libweston/renderer-g2d/g2d-renderer.c | 1 +
18 1 file changed, 1 insertion(+)
19
20diff --git a/libweston/renderer-g2d/g2d-renderer.c b/libweston/renderer-g2d/g2d-renderer.c
21index f59fc4ee..36a458fc 100644
22--- a/libweston/renderer-g2d/g2d-renderer.c
23+++ b/libweston/renderer-g2d/g2d-renderer.c
24@@ -41,6 +41,7 @@
25 #include <drm_fourcc.h>
26 #include <poll.h>
27 #include <errno.h>
28+#include <sys/stat.h> /* stat() */
29
30 #include <libweston/libweston.h>
31 #include "g2d-renderer.h"
32--
332.37.3
34
diff --git a/recipes-graphics/wayland/weston/0001-tests-Add-dependency-on-screenshooter-client-protoco.patch b/recipes-graphics/wayland/weston/0001-tests-Add-dependency-on-screenshooter-client-protoco.patch
deleted file mode 100644
index 46538600..00000000
--- a/recipes-graphics/wayland/weston/0001-tests-Add-dependency-on-screenshooter-client-protoco.patch
+++ /dev/null
@@ -1,33 +0,0 @@
1From 2ac6b6b084a877adde64db7faff2ed22eb3ea97a Mon Sep 17 00:00:00 2001
2From: Daniel Stone <daniels@collabora.com>
3Date: Tue, 8 Feb 2022 22:39:42 +0000
4Subject: [PATCH] tests: Add dependency on screenshooter client protocol
5
6Given that the test-helper code relies on the screenshooter protocol,
7make sure it's available for us to build, and the dependency ensures we
8build in order.
9
10Fixes: #588
11
12Signed-off-by: Daniel Stone <daniels@collabora.com>
13---
14 tests/meson.build | 3 ++-
15 1 file changed, 2 insertions(+), 1 deletion(-)
16
17diff --git a/tests/meson.build b/tests/meson.build
18index 2d464ddcc..222091cd1 100644
19--- a/tests/meson.build
20+++ b/tests/meson.build
21@@ -29,8 +29,9 @@ lib_test_client = static_library(
22 'weston-test-client-helper.c',
23 'weston-test-fixture-compositor.c',
24 weston_test_client_protocol_h,
25- weston_screenshooter_protocol_c,
26 weston_test_protocol_c,
27+ weston_screenshooter_client_protocol_h,
28+ weston_screenshooter_protocol_c,
29 viewporter_client_protocol_h,
30 viewporter_protocol_c,
31 'color_util.h',
32
33
diff --git a/recipes-graphics/wayland/weston/xwayland.weston-start b/recipes-graphics/wayland/weston/xwayland.weston-start
index db384b1a..342ac8d1 100644
--- a/recipes-graphics/wayland/weston/xwayland.weston-start
+++ b/recipes-graphics/wayland/weston/xwayland.weston-start
@@ -1,5 +1,6 @@
1#!/bin/sh 1#!/bin/sh
2 2
3if type Xwayland >/dev/null 2>/dev/null; then 3if type Xwayland >/dev/null 2>/dev/null; then
4 mkdir -p /tmp/.X11-unix 4 mkdir -m 775 -p /tmp/.X11-unix
5 chown root:video /tmp/.X11-unix
5fi 6fi