summaryrefslogtreecommitdiffstats
path: root/recipes-graphics/wayland/weston-init.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-graphics/wayland/weston-init.bbappend')
-rw-r--r--recipes-graphics/wayland/weston-init.bbappend26
1 files changed, 13 insertions, 13 deletions
diff --git a/recipes-graphics/wayland/weston-init.bbappend b/recipes-graphics/wayland/weston-init.bbappend
index ebd98268..e6baac0b 100644
--- a/recipes-graphics/wayland/weston-init.bbappend
+++ b/recipes-graphics/wayland/weston-init.bbappend
@@ -1,24 +1,24 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" 1FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
2 2
3# OpenGL is not required for parts with GPU support for 2D but not 3D 3# OpenGL is not required for parts with GPU support for 2D but not 3D
4IMX_REQUIRED_DISTRO_FEATURES_REMOVE = "" 4IMX_REQUIRED_DISTRO_FEATURES_REMOVE = ""
5IMX_REQUIRED_DISTRO_FEATURES_REMOVE_imxgpu2d = "opengl" 5IMX_REQUIRED_DISTRO_FEATURES_REMOVE:imxgpu2d = "opengl"
6IMX_REQUIRED_DISTRO_FEATURES_REMOVE_imxgpu3d = "" 6IMX_REQUIRED_DISTRO_FEATURES_REMOVE:imxgpu3d = ""
7REQUIRED_DISTRO_FEATURES_remove = "${IMX_REQUIRED_DISTRO_FEATURES_REMOVE}" 7REQUIRED_DISTRO_FEATURES:remove = "${IMX_REQUIRED_DISTRO_FEATURES_REMOVE}"
8 8
9SRC_URI_append_mx6sl = " file://weston.config" 9SRC_URI:append:mx6sl = " file://weston.config"
10 10
11# To customize weston.ini, start by setting the desired assignment in weston.ini, 11# To customize weston.ini, start by setting the desired assignment in weston.ini,
12# commented out. For example: 12# commented out. For example:
13# #xwayland=true 13# #xwayland=true
14# Then add the assignment to INI_UNCOMMENT_ASSIGNMENTS. 14# Then add the assignment to INI_UNCOMMENT_ASSIGNMENTS.
15INI_UNCOMMENT_ASSIGNMENTS_append_imx = " \ 15INI_UNCOMMENT_ASSIGNMENTS:append_imx = " \
16 ${@bb.utils.contains('DISTRO_FEATURES', 'x11 wayland', 'xwayland=true', '', d)} \ 16 ${@bb.utils.contains('DISTRO_FEATURES', 'x11 wayland', 'xwayland=true', '', d)} \
17" 17"
18INI_UNCOMMENT_ASSIGNMENTS_append_mx8 = " \ 18INI_UNCOMMENT_ASSIGNMENTS:append:mx8 = " \
19 repaint-window=16 \ 19 repaint-window=16 \
20" 20"
21INI_UNCOMMENT_ASSIGNMENTS_append_mx8mq = " \ 21INI_UNCOMMENT_ASSIGNMENTS:append:mx8mq = " \
22 gbm-format=argb8888 \ 22 gbm-format=argb8888 \
23 \\[shell\\] \ 23 \\[shell\\] \
24 size=1920x1080 \ 24 size=1920x1080 \
@@ -27,10 +27,10 @@ INI_UNCOMMENT_ASSIGNMENTS_append_mx8mq = " \
27# FIXME: The 8QM and 8QXP SoCs have better performance without G2D so don't enable it 27# FIXME: The 8QM and 8QXP SoCs have better performance without G2D so don't enable it
28# Ideally, this should be seamless and Vivante ought to handle it internally and take the fastest 28# Ideally, this should be seamless and Vivante ought to handle it internally and take the fastest
29# rendering code. 29# rendering code.
30INI_UNCOMMENT_USE_G2D_imxgpu2d ?= "use-g2d=1" 30INI_UNCOMMENT_USE_G2D:imxgpu2d ?= "use-g2d=1"
31INI_UNCOMMENT_USE_G2D_mx8qm = "" 31INI_UNCOMMENT_USE_G2D:mx8qm = ""
32INI_UNCOMMENT_USE_G2D_mx8qxp = "" 32INI_UNCOMMENT_USE_G2D:mx8qxp = ""
33INI_UNCOMMENT_ASSIGNMENTS_append_imxgpu2d = " \ 33INI_UNCOMMENT_ASSIGNMENTS:append:imxgpu2d = " \
34 ${INI_UNCOMMENT_USE_G2D} \ 34 ${INI_UNCOMMENT_USE_G2D} \
35" 35"
36 36
@@ -41,7 +41,7 @@ uncomment() {
41 sed -i -e 's,^#'"$1"','"$1"',g' $2 41 sed -i -e 's,^#'"$1"','"$1"',g' $2
42} 42}
43 43
44do_install_append() { 44do_install:append() {
45 if [ -f "${WORKDIR}/weston.config" ]; then 45 if [ -f "${WORKDIR}/weston.config" ]; then
46 install -Dm0755 ${WORKDIR}/weston.config ${D}${sysconfdir}/default/weston 46 install -Dm0755 ${WORKDIR}/weston.config ${D}${sysconfdir}/default/weston
47 fi 47 fi