summaryrefslogtreecommitdiffstats
path: root/recipes-graphics/wayland/wayland-protocols/0002-unstable-Add-hdr10-metadata-protocol.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-graphics/wayland/wayland-protocols/0002-unstable-Add-hdr10-metadata-protocol.patch')
-rw-r--r--recipes-graphics/wayland/wayland-protocols/0002-unstable-Add-hdr10-metadata-protocol.patch134
1 files changed, 0 insertions, 134 deletions
diff --git a/recipes-graphics/wayland/wayland-protocols/0002-unstable-Add-hdr10-metadata-protocol.patch b/recipes-graphics/wayland/wayland-protocols/0002-unstable-Add-hdr10-metadata-protocol.patch
deleted file mode 100644
index 01cac46e..00000000
--- a/recipes-graphics/wayland/wayland-protocols/0002-unstable-Add-hdr10-metadata-protocol.patch
+++ /dev/null
@@ -1,134 +0,0 @@
1From 54e847c10a75ec7bd6fbb8fbdd700d085145cdce Mon Sep 17 00:00:00 2001
2From: Haihua Hu <jared.hu@nxp.com>
3Date: Tue, 26 Jun 2018 15:30:18 +0800
4Subject: [PATCH 2/2] unstable: Add hdr10-metadata protocol
5
6this protocol is used to support hdr10 video playback.
7HDR10 metadata is passed to compositor via this interface
8
9Upstream-Status: Inappropriate [i.MX specific]
10
11Signed-off-by: Haihua Hu <jared.hu@nxp.com>
12---
13 Makefile.am | 1 +
14 unstable/hdr10-metadata/README | 4 ++
15 .../hdr10-metadata/hdr10-metadata-unstable-v1.xml | 84 ++++++++++++++++++++++
16 3 files changed, 89 insertions(+)
17 create mode 100644 unstable/hdr10-metadata/README
18 create mode 100644 unstable/hdr10-metadata/hdr10-metadata-unstable-v1.xml
19
20diff --git a/Makefile.am b/Makefile.am
21index e6c44ec..b8206c7 100644
22--- a/Makefile.am
23+++ b/Makefile.am
24@@ -24,6 +24,7 @@ unstable_protocols = \
25 unstable/linux-explicit-synchronization/linux-explicit-synchronization-unstable-v1.xml \
26 unstable/primary-selection/primary-selection-unstable-v1.xml \
27 unstable/alpha-compositing/alpha-compositing-unstable-v1.xml \
28+ unstable/hdr10-metadata/hdr10-metadata-unstable-v1.xml \
29 $(NULL)
30
31 stable_protocols = \
32diff --git a/unstable/hdr10-metadata/README b/unstable/hdr10-metadata/README
33new file mode 100644
34index 0000000..58a82f8
35--- /dev/null
36+++ b/unstable/hdr10-metadata/README
37@@ -0,0 +1,4 @@
38+hdr10 metadata protocol
39+
40+Maintainers:
41+Jared Hu <Jared Hu at nxp.com>
42diff --git a/unstable/hdr10-metadata/hdr10-metadata-unstable-v1.xml b/unstable/hdr10-metadata/hdr10-metadata-unstable-v1.xml
43new file mode 100644
44index 0000000..5b1bac4
45--- /dev/null
46+++ b/unstable/hdr10-metadata/hdr10-metadata-unstable-v1.xml
47@@ -0,0 +1,84 @@
48+<?xml version="1.0" encoding="UTF-8"?>
49+<protocol name="hdr10_metadata_unstable_v1">
50+
51+ <copyright>
52+ Copyright 2018 NXP
53+
54+ Permission is hereby granted, free of charge, to any person obtaining a
55+ copy of this software and associated documentation files (the "Software"),
56+ to deal in the Software without restriction, including without limitation
57+ the rights to use, copy, modify, merge, publish, distribute, sublicense,
58+ and/or sell copies of the Software, and to permit persons to whom the
59+ Software is furnished to do so, subject to the following conditions:
60+
61+ The above copyright notice and this permission notice (including the next
62+ paragraph) shall be included in all copies or substantial portions of the
63+ Software.
64+
65+ THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
66+ IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
67+ FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL
68+ THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
69+ LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING
70+ FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER
71+ DEALINGS IN THE SOFTWARE.
72+ </copyright>
73+
74+ <description summary="Protocol for sending hdr10 metadata to compositor">
75+ This protocol specifies a set of interfaces used to set and control
76+ hdr10 metadata of video contents.
77+
78+ Warning! The protocol described in this file is experimental and backward
79+ incompatible changes may be made. Backward compatible changes may be added
80+ together with the corresponding interface version bump. Backward
81+ incompatible changes are done by bumping the version number in the protocol
82+ and interface names and resetting the interface version. Once the protocol
83+ is to be declared stable, the 'z' prefix and the version number in the
84+ protocol and interface names are removed and the interface version number is
85+ reset.
86+ </description>
87+
88+ <interface name="zwp_hdr10_metadata_v1" version="1">
89+ <description summary="hdr10_metadata">
90+ The global interface exposing hdr10 metadata capabilities is
91+ used to instantiate an interface extension for compositor.
92+ This extended interface will then allow the client to pass hdr10 metadata
93+ to compositor and send to display driver if supported.
94+ </description>
95+
96+ <request name="destroy" type="destructor">
97+ <description summary="unbind from the hdr10 metadata interface">
98+ Informs the server that the client will not be using this
99+ protocol object anymore. This does not affect any other objects.
100+ </description>
101+ </request>
102+
103+ <enum name="error">
104+ <entry name="sending_meta_error" value="0"
105+ summary="error occurs when compositor handle metadata"/>
106+ </enum>
107+
108+ <request name="set_metadata">
109+ <description summary="interface of setting and controling hdr10 metadata">
110+ client can use this interface pass hdr10 metadata to server. Server need
111+ use the recived metadata to enable hdr mode.
112+ </description>
113+
114+ <arg name="eotf" type="uint" summary="supported eotf"/>
115+ <arg name="type" type="uint" summary="supported type"/>
116+ <arg name="display_primaries_red" type="uint"
117+ summary="display primaries of red, high 16bits for x, and low 16bits for y"/>
118+ <arg name="display_primaries_green" type="uint"
119+ summary="display primaries of green, high 16bits for x, and low 16bits for y"/>
120+ <arg name="display_primaries_blue" type="uint"
121+ summary="display primaries of blue, high 16bits for x, and low 16bits for y"/>
122+ <arg name="white_point" type="uint"
123+ summary="white point, high 16bits for x, and low 16bits for blue"/>
124+ <arg name="mastering_display_luminance" type="uint"
125+ summary="max and min mastering display luminance, high 16 bits for max, and low 16 bits for min"/>
126+ <arg name="max_cll" type="uint" summary="max content light level"/>
127+ <arg name="max_fall" type="uint" summary="max frame average light level"/>
128+ </request>
129+ </interface>
130+
131+</protocol>
132--
1332.7.4
134