diff options
Diffstat (limited to 'recipes-graphics/imx-gpu-viv')
4 files changed, 0 insertions, 377 deletions
diff --git a/recipes-graphics/imx-gpu-viv/files/egl-Add-EGL_PLATFORM_GBM_KHR-alias-to-EGL_PLATFORM_G.patch b/recipes-graphics/imx-gpu-viv/files/egl-Add-EGL_PLATFORM_GBM_KHR-alias-to-EGL_PLATFORM_G.patch deleted file mode 100644 index 962e23b0..00000000 --- a/recipes-graphics/imx-gpu-viv/files/egl-Add-EGL_PLATFORM_GBM_KHR-alias-to-EGL_PLATFORM_G.patch +++ /dev/null | |||
@@ -1,32 +0,0 @@ | |||
1 | From ea7f5aaf5b073d9b36253c65c8b466cc5039528d Mon Sep 17 00:00:00 2001 | ||
2 | From: Otavio Salvador <otavio@ossystems.com.br> | ||
3 | Date: Fri, 15 Dec 2017 11:04:22 -0200 | ||
4 | Subject: [PATCH] egl: Add EGL_PLATFORM_GBM_KHR alias to EGL_PLATFORM_GBM_MESA | ||
5 | Organization: O.S. Systems Software LTDA. | ||
6 | |||
7 | New EGL code uses EGL_PLATFORM_GBM_KHR (for example weston) and the | ||
8 | value is the same, so we can provide an alias for it instead of | ||
9 | patching every code using it. | ||
10 | |||
11 | Upstream-Status: Pending | ||
12 | |||
13 | Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> | ||
14 | --- | ||
15 | gpu-core/usr/include/EGL/eglext.h | 1 + | ||
16 | 1 file changed, 1 insertion(+) | ||
17 | |||
18 | diff --git a/gpu-core/usr/include/EGL/eglext.h b/gpu-core/usr/include/EGL/eglext.h | ||
19 | index 5f8d906..8f3cbd5 100644 | ||
20 | --- a/gpu-core/usr/include/EGL/eglext.h | ||
21 | +++ b/gpu-core/usr/include/EGL/eglext.h | ||
22 | @@ -513,6 +513,7 @@ EGLAPI EGLBoolean EGLAPIENTRY eglExportDRMImageMESA (EGLDisplay dpy, EGLImageKHR | ||
23 | #ifndef EGL_MESA_platform_gbm | ||
24 | #define EGL_MESA_platform_gbm 1 | ||
25 | #define EGL_PLATFORM_GBM_MESA 0x31D7 | ||
26 | +#define EGL_PLATFORM_GBM_KHR EGL_PLATFORM_GBM_MESA | ||
27 | #endif /* EGL_MESA_platform_gbm */ | ||
28 | |||
29 | #ifndef EGL_NV_3dvision_surface | ||
30 | -- | ||
31 | 2.15.1 | ||
32 | |||
diff --git a/recipes-graphics/imx-gpu-viv/files/egl-Add-EGL_PLATFORM_X11_KHR-alias-to-EGL_PLATFORM_X.patch b/recipes-graphics/imx-gpu-viv/files/egl-Add-EGL_PLATFORM_X11_KHR-alias-to-EGL_PLATFORM_X.patch deleted file mode 100644 index 0d76bf4d..00000000 --- a/recipes-graphics/imx-gpu-viv/files/egl-Add-EGL_PLATFORM_X11_KHR-alias-to-EGL_PLATFORM_X.patch +++ /dev/null | |||
@@ -1,32 +0,0 @@ | |||
1 | From 2b17f76f1495ee7eda50a754f8149e5ff3d04312 Mon Sep 17 00:00:00 2001 | ||
2 | From: Otavio Salvador <otavio@ossystems.com.br> | ||
3 | Date: Wed, 13 Dec 2017 11:00:04 -0200 | ||
4 | Subject: [PATCH] egl: Add EGL_PLATFORM_X11_KHR alias to EGL_PLATFORM_X11_EXT | ||
5 | Organization: O.S. Systems Software LTDA. | ||
6 | |||
7 | New EGL code uses EGL_PLATFORM_X11_KHR (for example glmark2) and the | ||
8 | value is the same, so we can provide an alias for it instead of | ||
9 | patching every code using it. | ||
10 | |||
11 | Upstream-Status: Pending | ||
12 | |||
13 | Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> | ||
14 | --- | ||
15 | gpu-core/usr/include/EGL/eglext.h | 1 + | ||
16 | 1 file changed, 1 insertion(+) | ||
17 | |||
18 | diff --git a/gpu-core/usr/include/EGL/eglext.h b/gpu-core/usr/include/EGL/eglext.h | ||
19 | index d3c5f56..5f8d906 100644 | ||
20 | --- a/gpu-core/usr/include/EGL/eglext.h | ||
21 | +++ b/gpu-core/usr/include/EGL/eglext.h | ||
22 | @@ -450,6 +450,7 @@ EGLAPI EGLSurface EGLAPIENTRY eglCreatePlatformPixmapSurfaceEXT (EGLDisplay dpy, | ||
23 | #ifndef EGL_EXT_platform_x11 | ||
24 | #define EGL_EXT_platform_x11 1 | ||
25 | #define EGL_PLATFORM_X11_EXT 0x31D5 | ||
26 | +#define EGL_PLATFORM_X11_KHR EGL_PLATFORM_X11_EXT | ||
27 | #define EGL_PLATFORM_X11_SCREEN_EXT 0x31D6 | ||
28 | #endif /* EGL_EXT_platform_x11 */ | ||
29 | |||
30 | -- | ||
31 | 2.15.1 | ||
32 | |||
diff --git a/recipes-graphics/imx-gpu-viv/imx-gpu-viv.inc b/recipes-graphics/imx-gpu-viv/imx-gpu-viv.inc deleted file mode 100644 index 5def1db5..00000000 --- a/recipes-graphics/imx-gpu-viv/imx-gpu-viv.inc +++ /dev/null | |||
@@ -1,306 +0,0 @@ | |||
1 | # Copyright (C) 2012-2016 Freescale Semiconductor | ||
2 | # Copyright (C) 2012-2016 O.S. Systems Software LTDA. | ||
3 | # Released under the MIT license (see COPYING.MIT for the terms) | ||
4 | |||
5 | DESCRIPTION = "GPU driver and apps for imx6" | ||
6 | SECTION = "libs" | ||
7 | LICENSE = "Proprietary" | ||
8 | LIC_FILES_CHKSUM = "file://gpu-core/usr/include/gc_vdk.h;beginline=5;endline=11;md5=12c028cbbbedb4b8770267131500592c" | ||
9 | |||
10 | DEPENDS += " \ | ||
11 | ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland', \ | ||
12 | bb.utils.contains('DISTRO_FEATURES', 'x11', 'virtual/libx11 libxdamage libxext libxfixes', \ | ||
13 | '', d), d)} \ | ||
14 | libpng \ | ||
15 | " | ||
16 | |||
17 | # imx-gpu-viv does not provide everything it needs to for virtual/libgl | ||
18 | # on x11 backend or on Wayland backend with XWayland support. | ||
19 | # We depend on mesa to fill in what is missing. | ||
20 | DEPENDS += "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'mesa', '', d)}" | ||
21 | |||
22 | EXTRA_PROVIDES = "" | ||
23 | EXTRA_PROVIDES_imxgpu3d = " virtual/libgl virtual/libgles1 virtual/libgles2" | ||
24 | PROVIDES += "virtual/wayland-egl virtual/libgal-x11 virtual/egl virtual/libopenvg virtual/libg2d ${EXTRA_PROVIDES}" | ||
25 | |||
26 | PE = "1" | ||
27 | |||
28 | inherit fsl-eula-unpack | ||
29 | |||
30 | SRC_URI = "${FSL_MIRROR}/${PN}-${PV}.bin;fsl-eula=true \ | ||
31 | file://egl-Add-EGL_PLATFORM_X11_KHR-alias-to-EGL_PLATFORM_X.patch \ | ||
32 | file://egl-Add-EGL_PLATFORM_GBM_KHR-alias-to-EGL_PLATFORM_G.patch" | ||
33 | |||
34 | PACKAGES =+ "libclc-mx6 libclc-mx6-dev \ | ||
35 | libgl-mx6 libgl-mx6-dev \ | ||
36 | libgles-mx6 libgles-mx6-dev \ | ||
37 | libgles2-mx6 libgles2-mx6-dev \ | ||
38 | libgles3-mx6-dev \ | ||
39 | libglslc-mx6 libglslc-mx6-dev \ | ||
40 | libopencl-mx6 libopencl-mx6-dev \ | ||
41 | libopenvg-mx6 libopenvg-mx6-dev \ | ||
42 | libvdk-mx6 libvdk-mx6-dev \ | ||
43 | libegl-mx6 libegl-mx6-dev \ | ||
44 | libgal-mx6 libgal-mx6-dev \ | ||
45 | libvivante-mx6 libvivante-mx6-dev \ | ||
46 | libvivante-dri-mx6 \ | ||
47 | libvsc-mx6 \ | ||
48 | libwayland-viv-mx6 libwayland-viv-mx6-dev \ | ||
49 | libgc-wayland-protocol-mx6 libgc-wayland-protocol-mx6-dev \ | ||
50 | libwayland-egl-mx6-dev \ | ||
51 | imx-gpu-viv-g2d imx-gpu-viv-g2d-dev \ | ||
52 | imx-gpu-viv-tools \ | ||
53 | imx-gpu-viv-tools-apitrace \ | ||
54 | imx-gpu-viv-demos \ | ||
55 | " | ||
56 | |||
57 | python __anonymous () { | ||
58 | has_vivante_kernel_driver_support = (d.getVar('MACHINE_HAS_VIVANTE_KERNEL_DRIVER_SUPPORT', True) or '0') | ||
59 | if has_vivante_kernel_driver_support != '1': | ||
60 | raise bb.parse.SkipPackage('The kernel of machine needs to have Vivante kernel driver support for this recipe to be used.') | ||
61 | } | ||
62 | |||
63 | HAS_X11 = "${@bb.utils.contains("DISTRO_FEATURES", "x11", "yes", "no", d)}" | ||
64 | HAS_WL = "${@bb.utils.contains("DISTRO_FEATURES", "wayland", "yes", "no", d)}" | ||
65 | |||
66 | # Inhibit warnings about files being stripped. | ||
67 | INHIBIT_PACKAGE_STRIP = "1" | ||
68 | INHIBIT_PACKAGE_DEBUG_SPLIT = "1" | ||
69 | |||
70 | # FIXME: The provided binary doesn't provide soname. If in future BSP | ||
71 | # release the libraries are fixed, we can drop this hack. | ||
72 | REALSOLIBS := "${SOLIBS}" | ||
73 | SOLIBS = "${SOLIBSDEV}" | ||
74 | |||
75 | # For the packages that make up the OpenGL interfaces, inject variables so that | ||
76 | # they don't get Debian-renamed (which would remove the -mx6 suffix). | ||
77 | # | ||
78 | # FIXME: All binaries lack GNU_HASH in elf binary but as we don't have | ||
79 | # the source we cannot fix it. Disable the insane check for now. | ||
80 | python __anonymous() { | ||
81 | packages = d.getVar('PACKAGES', True).split() | ||
82 | for p in packages: | ||
83 | d.appendVar("INSANE_SKIP_%s" % p, " ldflags") | ||
84 | |||
85 | for p in (("libegl", "libegl1"), ("libgl", "libgl1"), | ||
86 | ("libgles1", "libglesv1-cm1"), ("libgles2", "libglesv2-2"), | ||
87 | ("libgles3",)): | ||
88 | fullp = p[0] + "-mx6" | ||
89 | pkgs = " ".join(p) | ||
90 | d.setVar("DEBIAN_NOAUTONAME_" + fullp, "1") | ||
91 | d.appendVar("RREPLACES_" + fullp, pkgs) | ||
92 | d.appendVar("RPROVIDES_" + fullp, pkgs) | ||
93 | d.appendVar("RCONFLICTS_" + fullp, pkgs) | ||
94 | |||
95 | # For -dev, the first element is both the Debian and original name | ||
96 | fullp += "-dev" | ||
97 | pkgs = p[0] + "-dev" | ||
98 | d.setVar("DEBIAN_NOAUTONAME_" + fullp, "1") | ||
99 | d.appendVar("RREPLACES_" + fullp, pkgs) | ||
100 | d.appendVar("RPROVIDES_" + fullp, pkgs) | ||
101 | d.appendVar("RCONFLICTS_" + fullp, pkgs) | ||
102 | } | ||
103 | |||
104 | IMXGPU_imxgpu3d = "3d" | ||
105 | IMXGPU_imxgpu2d = "2d" | ||
106 | |||
107 | do_install () { | ||
108 | install -d ${D}${libdir} | ||
109 | install -d ${D}${includedir} | ||
110 | install -d ${D}${bindir} | ||
111 | |||
112 | cp -P ${S}/gpu-core/usr/lib/*.so* ${D}${libdir} | ||
113 | cp ${S}/g2d/usr/lib/*.so* ${D}${libdir} | ||
114 | cp -r ${S}/gpu-core/usr/include/* ${D}${includedir} | ||
115 | cp -Pr ${S}/g2d/usr/include/* ${D}${includedir} | ||
116 | cp -r ${S}/gpu-demos/opt ${D} | ||
117 | cp -r ${S}/gpu-tools/gmem-info/usr/bin/* ${D}${bindir} | ||
118 | |||
119 | install -d ${D}${libdir}/pkgconfig | ||
120 | |||
121 | # The preference order, based in DISTRO_FEATURES, is Wayland (with or without X11), X11 and fb | ||
122 | if [ "${HAS_WL}" = "yes" ]; then | ||
123 | cp -r ${S}/apitrace/non-x11/usr/lib/* ${D}${libdir} | ||
124 | cp -r ${S}/apitrace/non-x11/usr/bin/* ${D}${bindir} | ||
125 | |||
126 | backend=wl | ||
127 | |||
128 | install -m 0644 ${S}/gpu-core/usr/lib/pkgconfig/egl_wayland.pc ${D}${libdir}/pkgconfig/egl.pc | ||
129 | install -m 0644 ${S}/gpu-core/usr/lib/pkgconfig/glesv1_cm.pc ${D}${libdir}/pkgconfig/glesv1_cm.pc | ||
130 | install -m 0644 ${S}/gpu-core/usr/lib/pkgconfig/glesv2.pc ${D}${libdir}/pkgconfig/glesv2.pc | ||
131 | install -m 0644 ${S}/gpu-core/usr/lib/pkgconfig/vg.pc ${D}${libdir}/pkgconfig/vg.pc | ||
132 | install -m 0644 ${S}/gpu-core/usr/lib/pkgconfig/gc_wayland_protocol.pc ${D}${libdir}/pkgconfig/gc_wayland_protocol.pc | ||
133 | install -m 0644 ${S}/gpu-core/usr/lib/pkgconfig/wayland-egl.pc ${D}${libdir}/pkgconfig/wayland-egl.pc | ||
134 | install -m 0644 ${S}/gpu-core/usr/lib/pkgconfig/wayland-viv.pc ${D}${libdir}/pkgconfig/wayland-viv.pc | ||
135 | |||
136 | if [ "${HAS_X11}" = "yes" ]; then | ||
137 | cp -r ${S}/gpu-core/usr/lib/dri ${D}${libdir} | ||
138 | fi | ||
139 | |||
140 | elif [ "${HAS_X11}" = "yes" ]; then | ||
141 | |||
142 | cp -r ${S}/gpu-core/usr/lib/dri ${D}${libdir} | ||
143 | cp -r ${S}/apitrace/x11/usr/lib/* ${D}${libdir} | ||
144 | cp -r ${S}/apitrace/x11/usr/bin/* ${D}${bindir} | ||
145 | |||
146 | backend=x11 | ||
147 | |||
148 | install -m 0644 ${S}/gpu-core/usr/lib/pkgconfig/egl_x11.pc ${D}${libdir}/pkgconfig/egl.pc | ||
149 | install -m 0644 ${S}/gpu-core/usr/lib/pkgconfig/glesv1_cm_x11.pc ${D}${libdir}/pkgconfig/glesv1_cm.pc | ||
150 | install -m 0644 ${S}/gpu-core/usr/lib/pkgconfig/glesv2_x11.pc ${D}${libdir}/pkgconfig/glesv2.pc | ||
151 | install -m 0644 ${S}/gpu-core/usr/lib/pkgconfig/vg_x11.pc ${D}${libdir}/pkgconfig/vg.pc | ||
152 | else | ||
153 | install -m 0644 ${S}/gpu-core/usr/lib/pkgconfig/glesv1_cm.pc ${D}${libdir}/pkgconfig/glesv1_cm.pc | ||
154 | install -m 0644 ${S}/gpu-core/usr/lib/pkgconfig/glesv2.pc ${D}${libdir}/pkgconfig/glesv2.pc | ||
155 | install -m 0644 ${S}/gpu-core/usr/lib/pkgconfig/vg.pc ${D}${libdir}/pkgconfig/vg.pc | ||
156 | |||
157 | # Regular framebuffer | ||
158 | install -m 0644 ${S}/gpu-core/usr/lib/pkgconfig/egl_linuxfb.pc ${D}${libdir}/pkgconfig/egl.pc | ||
159 | cp -r ${S}/apitrace/non-x11/usr/lib/* ${D}${libdir} | ||
160 | cp -r ${S}/apitrace/non-x11/usr/bin/* ${D}${bindir} | ||
161 | backend=fb | ||
162 | fi | ||
163 | |||
164 | # Install Vendor ICDs for OpenCL's installable client driver loader (ICDs Loader) | ||
165 | install -d ${D}${sysconfdir}/OpenCL/vendors/ | ||
166 | install -m 0644 ${S}/gpu-core/etc/Vivante.icd ${D}${sysconfdir}/OpenCL/vendors/Vivante.icd | ||
167 | |||
168 | # We'll only have one backend here so we rename it to generic name | ||
169 | # and avoid rework in other packages, when possible | ||
170 | mv ${D}${libdir}/libGL.so.1.2 ${D}${libdir}/libGL.so.1.2.0 | ||
171 | ln -sf libGL.so.1.2.0 ${D}${libdir}/libGL.so.1.2 | ||
172 | ln -sf libGL.so.1.2.0 ${D}${libdir}/libGL.so.1 | ||
173 | ln -sf libGL.so.1.2.0 ${D}${libdir}/libGL.so | ||
174 | mv ${D}${libdir}/libEGL-${backend}.so ${D}${libdir}/libEGL.so.1.0 | ||
175 | ln -sf libEGL.so.1.0 ${D}${libdir}/libEGL.so.1 | ||
176 | ln -sf libEGL.so.1.0 ${D}${libdir}/libEGL.so | ||
177 | mv ${D}${libdir}/libGAL-${backend}.so ${D}${libdir}/libGAL.so | ||
178 | mv ${D}${libdir}/libVIVANTE-${backend}.so ${D}${libdir}/libVIVANTE.so | ||
179 | |||
180 | # update libglesv2 as backend dependent | ||
181 | rm -rf ${D}${libdir}/libGLESv2* | ||
182 | cp ${S}/gpu-core/usr/lib/libGLESv2-${backend}.so ${D}${libdir}/libGLESv2.so.2.0.0 | ||
183 | ln -sf libGLESv2.so.2.0.0 ${D}${libdir}/libGLESv2.so.2 | ||
184 | ln -sf libGLESv2.so.2.0.0 ${D}${libdir}/libGLESv2.so | ||
185 | |||
186 | # skip packaging wayland libraries if no support is requested | ||
187 | if [ "${HAS_WL}" = "no" ]; then | ||
188 | rm ${D}${libdir}/libgc_wayland_protocol.* | ||
189 | rm ${D}${libdir}/libwayland-viv.* | ||
190 | fi | ||
191 | |||
192 | for backend in wl x11 fb dri; do | ||
193 | find ${D}${libdir} -name "*-$backend.so" -exec rm '{}' ';' | ||
194 | find ${D}${libdir} -name "*.$backend.so" -exec rm '{}' ';' | ||
195 | done | ||
196 | |||
197 | # FIXME: For 2D only GPU, we need to remove some content which is | ||
198 | # 3D specific. | ||
199 | if [ "${IMXGPU}" = "2d" ]; then | ||
200 | rm -rf ${D}${libdir}/libCLC* ${D}${includedir}/CL \ | ||
201 | \ | ||
202 | ${D}${libdir}/libGL* ${D}${includedir}/GL* \ | ||
203 | \ | ||
204 | ${D}${libdir}/libGLES* ${D}${libdir}/pkgconfig/glesv1_cm.pc ${D}${libdir}/pkgconfig/glesv2.pc \ | ||
205 | \ | ||
206 | ${D}${libdir}/libOpenCL* ${D}${includedir}/CL \ | ||
207 | \ | ||
208 | ${D}${libdir}/libOpenVG.so ${D}${libdir}/libOpenVG.3d.so \ | ||
209 | \ | ||
210 | ${D}${libdir}/libVivanteOpenCL.so \ | ||
211 | \ | ||
212 | ${D}/opt/viv_samples/vdk \ | ||
213 | ${D}/opt/viv_samples/es20 ${D}/opt/viv_samples/cl11 | ||
214 | |||
215 | ln -sf libOpenVG.2d.so ${D}${libdir}/libOpenVG.so | ||
216 | fi | ||
217 | |||
218 | find ${D}${libdir} -type f -exec chmod 644 {} \; | ||
219 | find ${D}${includedir} -type f -exec chmod 644 {} \; | ||
220 | |||
221 | chown -R root:root "${D}" | ||
222 | } | ||
223 | |||
224 | ALLOW_EMPTY_${PN} = "1" | ||
225 | |||
226 | FILES_libclc-mx6 = "${libdir}/libCLC${SOLIBS}" | ||
227 | FILES_libclc-mx6-dev = "${includedir}/CL ${libdir}/libCLC${SOLIBSDEV}" | ||
228 | |||
229 | # libEGL.so is used by some demo apps from Freescale | ||
230 | INSANE_SKIP_libegl-mx6 += "dev-so" | ||
231 | FILES_libegl-mx6 = "${libdir}/libEGL${REALSOLIBS} ${libdir}/libEGL${SOLIBSDEV} " | ||
232 | FILES_libegl-mx6-dev = "${includedir}/EGL ${includedir}/KHR ${libdir}/pkgconfig/egl.pc" | ||
233 | |||
234 | FILES_libgal-mx6 = "${libdir}/libGAL${SOLIBS} ${libdir}/libGAL_egl${SOLIBS}" | ||
235 | FILES_libgal-mx6-dev = "${libdir}/libGAL${SOLIBSDEV} ${includedir}/HAL" | ||
236 | RDEPENDS_libgal-mx6 += "kernel-module-imx-gpu-viv" | ||
237 | INSANE_SKIP_libgal-mx6 += "build-deps" | ||
238 | |||
239 | FILES_libvsc-mx6 = "${libdir}/libVSC${SOLIBS}" | ||
240 | |||
241 | FILES_libgl-mx6 = "${libdir}/libGL${REALSOLIBS}" | ||
242 | FILES_libgl-mx6-dev = "${libdir}/libGL${SOLIBSDEV}" | ||
243 | # Includes GL headers from mesa | ||
244 | RDEPENDS_libgl-mx6-dev += "libgl-mesa-dev" | ||
245 | |||
246 | # libEGL needs to open libGLESv1.so | ||
247 | INSANE_SKIP_libgles-mx6 += "dev-so" | ||
248 | FILES_libgles-mx6 = "${libdir}/libGLESv1*${REALSOLIBS} ${libdir}/libGLESv1*${SOLIBS} ${libdir}/libGLES_*${REALSOLIBS} ${libdir}/libGLES_*${SOLIBS}" | ||
249 | FILES_libgles-mx6-dev = "${includedir}/GLES ${libdir}/libGLESv1*${SOLIBS} ${libdir}/libGLES_*${SOLIBSDEV} ${libdir}/pkgconfig/glesv1_cm.pc" | ||
250 | |||
251 | # libEGL needs to open libGLESv2.so | ||
252 | INSANE_SKIP_libgles2-mx6 += "dev-so" | ||
253 | FILES_libgles2-mx6 = "${libdir}/libGLESv2${REALSOLIBS} ${libdir}/libGLESv2${SOLIBS}" | ||
254 | FILES_libgles2-mx6-dev = "${includedir}/GLES2 ${libdir}/libGLESv2${SOLIBSDEV} ${libdir}/pkgconfig/glesv2.pc" | ||
255 | RDEPENDS_libgles2-mx6 = "libglslc-mx6" | ||
256 | |||
257 | FILES_libgles3-mx6-dev = "${includedir}/GLES3" | ||
258 | # as long as there is no libgles3-mx6: ship libgles3-mx6-dev along with | ||
259 | # libgles2-mx6-dev - otherwise GLES3 headers have to be added manually | ||
260 | RDEPENDS_libgles2-mx6-dev += "libgles3-mx6-dev" | ||
261 | |||
262 | FILES_libglslc-mx6 = "${libdir}/libGLSLC${SOLIBS}" | ||
263 | FILES_libglslc-mx6-dev = "${includedir}/CL ${libdir}/libGLSLC${SOLIBSDEV}" | ||
264 | |||
265 | FILES_libopencl-mx6 = "${libdir}/libOpenCL${SOLIBS} \ | ||
266 | ${libdir}/libVivanteOpenCL${SOLIBS} \ | ||
267 | ${sysconfdir}/OpenCL/vendors/Vivante.icd" | ||
268 | FILES_libopencl-mx6-dev = "${includedir}/CL ${libdir}/libOpenCL${SOLIBSDEV}" | ||
269 | RDEPENDS_libopencl-mx6 = "libclc-mx6" | ||
270 | |||
271 | INSANE_SKIP_libopenvg-mx6 += "dev-so" | ||
272 | FILES_libopenvg-mx6 = "${libdir}/libOpenVG*${SOLIBS}" | ||
273 | FILES_libopenvg-mx6-dev = "${includedir}/VG ${libdir}/libOpenVG*${SOLIBSDEV} ${libdir}/pkgconfig/vg.pc" | ||
274 | |||
275 | FILES_libvdk-mx6 = "${libdir}/libVDK${SOLIBS}" | ||
276 | FILES_libvdk-mx6-dev = "${includedir}/*vdk*.h ${libdir}/libVDK${SOLIBSDEV}" | ||
277 | |||
278 | FILES_libvivante-mx6 = "${libdir}/libVIVANTE${SOLIBS}" | ||
279 | FILES_libvivante-mx6-dev = "${libdir}/libVIVANTE${SOLIBSDEV}" | ||
280 | |||
281 | FILES_libvivante-dri-mx6 = "${libdir}/dri/vivante_dri.so" | ||
282 | RDEPENDS_libvivante-dri-mx6 = "libdrm" | ||
283 | |||
284 | INSANE_SKIP_libwayland-viv-mx6 += "dev-so" | ||
285 | FILES_libwayland-viv-mx6 = "${libdir}/libwayland-viv${REALSOLIBS} ${libdir}/libwayland-viv${SOLIBS}" | ||
286 | FILES_libwayland-viv-mx6-dev = "${includedir}/wayland-viv ${libdir})/libwayland-viv${SOLIBSDEV} ${libdir}/pkgconfig/wayland-viv.pc" | ||
287 | RPROVIDES_libwayland-viv-mx6 += "${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'xf86-video-imxfb-vivante', '', d)}" | ||
288 | |||
289 | INSANE_SKIP_libgc-wayland-protocol-mx6 += "dev-so" | ||
290 | FILES_libgc-wayland-protocol-mx6 = "${libdir}/libgc_wayland_protocol${REALSOLIBS} ${libdir}/libgc_wayland_protocol${SOLIBS}" | ||
291 | FILES_libgc-wayland-protocol-mx6-dev = "${libdir}/libgc_wayland_protocol${SOLIBSDEV} ${libdir}/pkgconfig/gc_wayland_protocol.pc" | ||
292 | |||
293 | FILES_libwayland-egl-mx6-dev = "${libdir}/pkgconfig/wayland-egl.pc" | ||
294 | |||
295 | INSANE_SKIP_imx-gpu-viv-g2d += "dev-so" | ||
296 | FILES_imx-gpu-viv-g2d = "${libdir}/libg2d* " | ||
297 | FILES_imx-gpu-viv-g2d-dev = "${includedir}/g2d.h" | ||
298 | |||
299 | FILES_imx-gpu-viv-tools = "${bindir}/gmem_info" | ||
300 | |||
301 | FILES_imx-gpu-viv-tools-apitrace = "${bindir} ${libdir}" | ||
302 | |||
303 | FILES_imx-gpu-viv-demos = "/opt" | ||
304 | INSANE_SKIP_imx-gpu-viv-demos += "rpaths" | ||
305 | |||
306 | COMPATIBLE_MACHINE = "(mx6q|mx6dl|mx6sx|mx6sl)" | ||
diff --git a/recipes-graphics/imx-gpu-viv/imx-gpu-viv_5.0.11.p8.6-hfp.bb b/recipes-graphics/imx-gpu-viv/imx-gpu-viv_5.0.11.p8.6-hfp.bb deleted file mode 100644 index d619a71c..00000000 --- a/recipes-graphics/imx-gpu-viv/imx-gpu-viv_5.0.11.p8.6-hfp.bb +++ /dev/null | |||
@@ -1,7 +0,0 @@ | |||
1 | # Copyright (C) 2013-2016 Freescale Semiconductor | ||
2 | # Released under the MIT license (see COPYING.MIT for the terms) | ||
3 | |||
4 | require imx-gpu-viv.inc | ||
5 | |||
6 | SRC_URI[md5sum] = "92fc34fc37b0865f61be1bd931f5166f" | ||
7 | SRC_URI[sha256sum] = "caaabd59a259e29aa5b7f9d1d7f3fe71cff9336ba44904485d258baef276351f" | ||