summaryrefslogtreecommitdiffstats
path: root/recipes-graphics/imx-g2d/imx-gpu-g2d_6.4.11.p2.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-graphics/imx-g2d/imx-gpu-g2d_6.4.11.p2.4.bb')
-rw-r--r--recipes-graphics/imx-g2d/imx-gpu-g2d_6.4.11.p2.4.bb44
1 files changed, 44 insertions, 0 deletions
diff --git a/recipes-graphics/imx-g2d/imx-gpu-g2d_6.4.11.p2.4.bb b/recipes-graphics/imx-g2d/imx-gpu-g2d_6.4.11.p2.4.bb
new file mode 100644
index 00000000..3ebb8f88
--- /dev/null
+++ b/recipes-graphics/imx-g2d/imx-gpu-g2d_6.4.11.p2.4.bb
@@ -0,0 +1,44 @@
1# Copyright (C) 2016 Freescale Semiconductor
2# Copyright 2017-2024 NXP
3# Copyright 2018 (C) O.S. Systems Software LTDA.
4# Released under the MIT license (see COPYING.MIT for the terms)
5
6DESCRIPTION = "G2D library using i.MX GPU"
7LICENSE = "Proprietary"
8LIC_FILES_CHKSUM = "file://COPYING;md5=44a8052c384584ba09077e85a3d1654f"
9DEPENDS = "libgal-imx"
10PROVIDES = "virtual/libg2d"
11
12SRC_URI = "${FSL_MIRROR}/${IMX_BIN_NAME}.bin;name=${TARGET_ARCH};fsl-eula=true"
13IMX_BIN_NAME = "${BP}-${TARGET_ARCH}-${IMX_SRCREV_ABBREV}"
14IMX_SRCREV_ABBREV = "b07999b"
15SRC_URI[aarch64.md5sum] = "fa30ce75803697d5131d707b300258ee"
16SRC_URI[aarch64.sha256sum] = "2dff0279ead132ec5fa61dbe9b2b1969135e8ce9fe7487957371327357d70ac7"
17SRC_URI[arm.md5sum] = "c81be7c93b60c7d3f3eb5b7bfeda42a4"
18SRC_URI[arm.sha256sum] = "e17ac373193622ec0c9aa490ef1b93551d22a2e88ee9f1098ed984e62f02a06c"
19
20S = "${WORKDIR}/${IMX_BIN_NAME}"
21
22inherit fsl-eula-unpack
23
24SOC_INSTALL_DIR = "SOC_INSTALL_DIR_NOT_SET"
25SOC_INSTALL_DIR:mx8mm-nxp-bsp = "mx8mm"
26
27do_install () {
28 install -d ${D}${libdir}
29 install -d ${D}${includedir}
30 cp -d ${S}/g2d/usr/lib/*.so* ${D}${libdir}
31 if [ -d ${S}/g2d/usr/lib/${SOC_INSTALL_DIR} ]; then
32 cp -d ${S}/g2d/usr/lib/${SOC_INSTALL_DIR}/*.so* ${D}${libdir}
33 fi
34 cp -Pr ${S}/g2d/usr/include/* ${D}${includedir}
35}
36
37# The packaged binaries have been stripped of debug info, so disable
38# operations accordingly.
39INHIBIT_PACKAGE_DEBUG_SPLIT = "1"
40INHIBIT_PACKAGE_STRIP = "1"
41INHIBIT_SYSROOT_STRIP = "1"
42
43PACKAGE_ARCH = "${MACHINE_SOCARCH}"
44COMPATIBLE_MACHINE = "(imxgpu2d)"