diff options
Diffstat (limited to 'recipes-graphics/imx-g2d/imx-dpu-g2d_2.2.0.bb')
-rw-r--r-- | recipes-graphics/imx-g2d/imx-dpu-g2d_2.2.0.bb | 47 |
1 files changed, 47 insertions, 0 deletions
diff --git a/recipes-graphics/imx-g2d/imx-dpu-g2d_2.2.0.bb b/recipes-graphics/imx-g2d/imx-dpu-g2d_2.2.0.bb new file mode 100644 index 00000000..5e8f5402 --- /dev/null +++ b/recipes-graphics/imx-g2d/imx-dpu-g2d_2.2.0.bb | |||
@@ -0,0 +1,47 @@ | |||
1 | # Copyright (C) 2016 Freescale Semiconductor | ||
2 | # Copyright 2017-2024 NXP | ||
3 | # Released under the MIT license (see COPYING.MIT for the terms) | ||
4 | |||
5 | DESCRIPTION = "G2D library using i.MX DPU" | ||
6 | LICENSE = "Proprietary" | ||
7 | LIC_FILES_CHKSUM = "file://COPYING;md5=ca53281cc0caa7e320d4945a896fb837" | ||
8 | |||
9 | DEPENDS = "libdrm ${LIBGAL_IMX}" | ||
10 | LIBGAL_IMX = "libgal-imx" | ||
11 | LIBGAL_IMX:mx95-nxp-bsp = "" | ||
12 | |||
13 | PROVIDES += "virtual/libg2d" | ||
14 | |||
15 | SRC_URI = "${FSL_MIRROR}/${IMX_BIN_NAME}.bin;fsl-eula=true;name=${IMX_SRC_URI_NAME}" | ||
16 | IMX_BIN_NAME = "${BPN}-${IMX_SRC_URI_NAME}-${PV}-${IMX_SRCREV_ABBREV}" | ||
17 | |||
18 | IMX_SRCREV_ABBREV = "7943590" | ||
19 | IMX_SRC_URI_NAME = "v1" | ||
20 | SRC_URI[v1.sha256sum] = "bf347f53e8f390a0554c0db76707819bb50cf4aaa564a9c86821ae9add26e113" | ||
21 | |||
22 | IMX_SRCREV_ABBREV:mx95-nxp-bsp = "7943590" | ||
23 | IMX_SRC_URI_NAME:mx95-nxp-bsp = "v2" | ||
24 | SRC_URI[v2.sha256sum] = "c0a87908cd04c208659423746a57eaee6a30b4d680ec871f3495ad4a2acb5076" | ||
25 | |||
26 | S = "${WORKDIR}/${IMX_BIN_NAME}" | ||
27 | |||
28 | inherit fsl-eula-unpack | ||
29 | |||
30 | do_install () { | ||
31 | install -d ${D}${libdir} | ||
32 | install -d ${D}${includedir} | ||
33 | cp -d ${S}/g2d/usr/lib/*.so* ${D}${libdir} | ||
34 | cp -Pr ${S}/g2d/usr/include/* ${D}${includedir} | ||
35 | } | ||
36 | |||
37 | INSANE_SKIP:append:libc-musl = " file-rdeps" | ||
38 | RDEPENDS:${PN}:append:libc-musl = " gcompat" | ||
39 | |||
40 | # The packaged binaries have been stripped of debug info, so disable | ||
41 | # operations accordingly. | ||
42 | INHIBIT_PACKAGE_DEBUG_SPLIT = "1" | ||
43 | INHIBIT_PACKAGE_STRIP = "1" | ||
44 | INHIBIT_SYSROOT_STRIP = "1" | ||
45 | |||
46 | PACKAGE_ARCH = "${MACHINE_SOCARCH}" | ||
47 | COMPATIBLE_MACHINE = "(imxdpu)" | ||