summaryrefslogtreecommitdiffstats
path: root/recipes-graphics/drm/libdrm/0001-configure.ac-Allow-explicit-enabling-of-cunit-tests.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-graphics/drm/libdrm/0001-configure.ac-Allow-explicit-enabling-of-cunit-tests.patch')
-rw-r--r--recipes-graphics/drm/libdrm/0001-configure.ac-Allow-explicit-enabling-of-cunit-tests.patch54
1 files changed, 0 insertions, 54 deletions
diff --git a/recipes-graphics/drm/libdrm/0001-configure.ac-Allow-explicit-enabling-of-cunit-tests.patch b/recipes-graphics/drm/libdrm/0001-configure.ac-Allow-explicit-enabling-of-cunit-tests.patch
deleted file mode 100644
index fa7b218e..00000000
--- a/recipes-graphics/drm/libdrm/0001-configure.ac-Allow-explicit-enabling-of-cunit-tests.patch
+++ /dev/null
@@ -1,54 +0,0 @@
1From 9be904a70e6b7e6b3cc4e1b270bca02d14a4179b Mon Sep 17 00:00:00 2001
2From: Jussi Kukkonen <jussi.kukkonen@intel.com>
3Date: Mon, 5 Sep 2016 14:41:37 +0300
4Subject: [PATCH] configure.ac: Allow explicit enabling of cunit tests
5
6Add --with-cunit to make it easier to do reproducible builds. Default
7is still to probe cunit and build opportunistically.
8
9Signed-off-by: Jussi Kukkonen <jussi.kukkonen@intel.com>
10Upstream-Status: Submitted [mailing list]
11
12---
13 configure.ac | 14 ++++++++++++--
14 1 file changed, 12 insertions(+), 2 deletions(-)
15
16diff --git a/configure.ac b/configure.ac
17index 1341f51..bef46e0 100644
18--- a/configure.ac
19+++ b/configure.ac
20@@ -168,6 +168,12 @@ AC_ARG_ENABLE(install-test-programs,
21 [Install test programs (default: no)]),
22 [INSTALL_TESTS=$enableval], [INSTALL_TESTS=no])
23
24+AC_ARG_WITH([cunit],
25+ [AS_HELP_STRING([--with-cunit],
26+ [Build tests that use cunit (default: auto)])],
27+ [],
28+ [with_cunit=auto])
29+
30 dnl ===========================================================================
31 dnl check compiler flags
32 AC_DEFUN([LIBDRM_CC_TRY_FLAG], [
33@@ -416,7 +422,7 @@ else
34 AC_DEFINE(HAVE_RADEON, 0)
35 fi
36
37-if test "x$AMDGPU" != xno; then
38+if test "x$with_cunit" != xno -a "x$AMDGPU" != xno; then
39 # Detect cunit library
40 PKG_CHECK_MODULES([CUNIT], [cunit >= 2.1], [have_cunit=yes], [have_cunit=no])
41 # If pkg-config does not find cunit, check it using AC_CHECK_LIB. We
42@@ -441,7 +447,11 @@ if test "x$AMDGPU" = xyes; then
43 AC_DEFINE(HAVE_AMDGPU, 1, [Have amdgpu support])
44
45 if test "x$have_cunit" = "xno"; then
46- AC_MSG_WARN([Could not find cunit library. Disabling amdgpu tests])
47+ if test "x$with_cunit" = "xyes"; then
48+ AC_MSG_ERROR([Could not find cunit library but --with-cunit was given])
49+ elif test "x$with_cunit" = "xauto"; then
50+ AC_MSG_WARN([Could not find cunit library. Disabling amdgpu tests])
51+ fi
52 fi
53 else
54 AC_DEFINE(HAVE_AMDGPU, 0)