summaryrefslogtreecommitdiffstats
path: root/recipes-graphics
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-graphics')
-rw-r--r--recipes-graphics/waffle/waffle/0001-meson-Add-missing-wayland-dependency-on-EGL.patch8
-rw-r--r--recipes-graphics/waffle/waffle/0002-meson-Separate-surfaceless-option-from-x11.patch22
2 files changed, 14 insertions, 16 deletions
diff --git a/recipes-graphics/waffle/waffle/0001-meson-Add-missing-wayland-dependency-on-EGL.patch b/recipes-graphics/waffle/waffle/0001-meson-Add-missing-wayland-dependency-on-EGL.patch
index 6f4be031..01849d92 100644
--- a/recipes-graphics/waffle/waffle/0001-meson-Add-missing-wayland-dependency-on-EGL.patch
+++ b/recipes-graphics/waffle/waffle/0001-meson-Add-missing-wayland-dependency-on-EGL.patch
@@ -18,7 +18,7 @@ Index: git/meson.build
18=================================================================== 18===================================================================
19--- git.orig/meson.build 19--- git.orig/meson.build
20+++ git/meson.build 20+++ git/meson.build
21@@ -65,6 +65,7 @@ dep_gl = _dep_null 21@@ -64,6 +64,7 @@ dep_drm = _dep_null
22 dep_egl = _dep_null 22 dep_egl = _dep_null
23 dep_wayland_client = _dep_null 23 dep_wayland_client = _dep_null
24 dep_wayland_egl = _dep_null 24 dep_wayland_egl = _dep_null
@@ -26,7 +26,7 @@ Index: git/meson.build
26 dep_wayland_scanner = _dep_null 26 dep_wayland_scanner = _dep_null
27 dep_wayland_proto = _dep_null 27 dep_wayland_proto = _dep_null
28 dep_x11_xcb = _dep_null 28 dep_x11_xcb = _dep_null
29@@ -106,7 +107,8 @@ else 29@@ -104,7 +105,8 @@ else
30 dep_wayland_client = dependency( 30 dep_wayland_client = dependency(
31 'wayland-client', version : '>= 1.10', required : get_option('wayland'), 31 'wayland-client', version : '>= 1.10', required : get_option('wayland'),
32 ) 32 )
@@ -36,7 +36,7 @@ Index: git/meson.build
36 'wayland-egl', version : '>= 9.1', required : get_option('wayland'), 36 'wayland-egl', version : '>= 9.1', required : get_option('wayland'),
37 ) 37 )
38 dep_wayland_scanner = dependency( 38 dep_wayland_scanner = dependency(
39@@ -124,7 +126,7 @@ else 39@@ -122,7 +124,7 @@ else
40 wayland_xdg_shell_xml = join_paths(dep_wayland_proto.get_variable(pkgconfig: 'pkgdatadir'), 40 wayland_xdg_shell_xml = join_paths(dep_wayland_proto.get_variable(pkgconfig: 'pkgdatadir'),
41 'stable/xdg-shell/xdg-shell.xml') 41 'stable/xdg-shell/xdg-shell.xml')
42 endif 42 endif
@@ -44,4 +44,4 @@ Index: git/meson.build
44+ build_wayland = dep_egl.found() and dep_wayland_client.found() and dep_wayland_egl.found() and dep_wayland_scanner.found() and dep_wayland_proto.found() and dep_wayland_wayland_egl.found() 44+ build_wayland = dep_egl.found() and dep_wayland_client.found() and dep_wayland_egl.found() and dep_wayland_scanner.found() and dep_wayland_proto.found() and dep_wayland_wayland_egl.found()
45 45
46 # We're interested only in the headers provided 46 # We're interested only in the headers provided
47 # FINISHME: make x11_xcb and udev compile-only dependency 47 # FINISHME: make x11_xcb compile-only dependency
diff --git a/recipes-graphics/waffle/waffle/0002-meson-Separate-surfaceless-option-from-x11.patch b/recipes-graphics/waffle/waffle/0002-meson-Separate-surfaceless-option-from-x11.patch
index 2a680cc6..01b2b040 100644
--- a/recipes-graphics/waffle/waffle/0002-meson-Separate-surfaceless-option-from-x11.patch
+++ b/recipes-graphics/waffle/waffle/0002-meson-Separate-surfaceless-option-from-x11.patch
@@ -14,9 +14,11 @@ Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
14 meson.build | 5 ++++- 14 meson.build | 5 ++++-
15 1 file changed, 4 insertions(+), 1 deletion(-) 15 1 file changed, 4 insertions(+), 1 deletion(-)
16 16
17--- a/meson.build 17Index: git/meson.build
18+++ b/meson.build 18===================================================================
19@@ -72,6 +72,7 @@ dep_udev = _dep_null 19--- git.orig/meson.build
20+++ git/meson.build
21@@ -72,6 +72,7 @@ dep_gbm = _dep_null
20 dep_cocoa = _dep_null 22 dep_cocoa = _dep_null
21 dep_core_foundation = _dep_null 23 dep_core_foundation = _dep_null
22 dep_gl_headers = _dep_null 24 dep_gl_headers = _dep_null
@@ -24,17 +26,13 @@ Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
24 26
25 # Get dependencies 27 # Get dependencies
26 if build_wgl 28 if build_wgl
27@@ -96,10 +97,11 @@ else 29@@ -99,7 +100,8 @@ else
28 dep_egl = dependency('egl', required : get_option('gbm')) 30 build_gbm = dep_drm.found() and dep_egl.found() and dep_gbm.found()
29 dep_gbm = dependency('gbm', required : get_option('gbm'))
30 dep_udev = dependency('libudev', required : get_option('gbm'))
31+ dep_surfaceless_egl = dependency('egl', required : get_option('surfaceless_egl'))
32+ dep_surfaceless_gbm = dependency('gbm', required : get_option('surfaceless_egl'))
33 build_gbm = dep_egl.found() and dep_gbm.found() and dep_udev.found()
34 31
35- dep_egl = dependency('egl', required : get_option('surfaceless_egl')) 32 dep_egl = dependency('egl', required : get_option('surfaceless_egl'))
36- build_surfaceless = dep_egl.found() 33- build_surfaceless = dep_egl.found()
37+ build_surfaceless = dep_surfaceless_egl.found() and dep_surfaceless_gbm.found() 34+ dep_gbm = dependency('gbm', required : get_option('surfaceless_egl'))
35+ build_surfaceless = dep_egl.found() and dep_gbm.found()
38 36
39 dep_egl = dependency('egl', required : get_option('wayland')) 37 dep_egl = dependency('egl', required : get_option('wayland'))
40 dep_wayland_client = dependency( 38 dep_wayland_client = dependency(