summaryrefslogtreecommitdiffstats
path: root/recipes-fsl/packagegroups/packagegroup-fsl-mfgtool.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-fsl/packagegroups/packagegroup-fsl-mfgtool.bb')
-rw-r--r--recipes-fsl/packagegroups/packagegroup-fsl-mfgtool.bb47
1 files changed, 47 insertions, 0 deletions
diff --git a/recipes-fsl/packagegroups/packagegroup-fsl-mfgtool.bb b/recipes-fsl/packagegroups/packagegroup-fsl-mfgtool.bb
new file mode 100644
index 00000000..50885ee1
--- /dev/null
+++ b/recipes-fsl/packagegroups/packagegroup-fsl-mfgtool.bb
@@ -0,0 +1,47 @@
1# Copyright (C) 2014 O.S. Systems Software LTDA.
2
3SUMMARY = "Freescale Manufacturing Tool requirements"
4LICENSE = "MIT"
5
6PACKAGE_ARCH = "${MACHINE_ARCH}"
7
8inherit packagegroup
9
10PACKAGES = " \
11 ${PN}-base \
12 ${PN}-mtd \
13 ${PN}-extfs \
14"
15
16# The essential packages for device bootup that may be set in the
17# machine configuration file.
18MACHINE_ESSENTIAL_EXTRA_RDEPENDS ?= ""
19
20# Distro can override the following VIRTUAL-RUNTIME providers:
21VIRTUAL-RUNTIME_keymaps ?= "keymaps"
22
23RDEPENDS_${PN}-base = " \
24 bash \
25 imx-uuc \
26 util-linux \
27 coreutils \
28 dosfstools \
29 mmc-utils \
30 base-files \
31 base-passwd \
32 busybox \
33 ${@base_contains("MACHINE_FEATURES", "keyboard", "${VIRTUAL-RUNTIME_keymaps}", "", d)} \
34 ${MACHINE_ESSENTIAL_EXTRA_RDEPENDS} \
35"
36
37RDEPENDS_${PN}-mtd = " \
38 ${PN}-base \
39 imx-kobs \
40 mtd-utils \
41 mtd-utils-ubifs \
42"
43
44RDEPENDS_${PN}-extfs = " \
45 ${PN}-base \
46 e2fsprogs-mke2fs \
47"