summaryrefslogtreecommitdiffstats
path: root/recipes-extended/dpdk/dpdk-extras_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-extended/dpdk/dpdk-extras_git.bb')
-rw-r--r--recipes-extended/dpdk/dpdk-extras_git.bb27
1 files changed, 0 insertions, 27 deletions
diff --git a/recipes-extended/dpdk/dpdk-extras_git.bb b/recipes-extended/dpdk/dpdk-extras_git.bb
deleted file mode 100644
index 15aec95e..00000000
--- a/recipes-extended/dpdk/dpdk-extras_git.bb
+++ /dev/null
@@ -1,27 +0,0 @@
1DESCRIPTION = "Data Plane Development Kit Extended utilities"
2HOMEPAGE = "http://dpdk.org"
3LICENSE = "BSD"
4LIC_FILES_CHKSUM = "file://COPYING;md5=4ac6ab4e4bcf4c79cb9257f3c61934f6"
5
6RDEPENDS_${PN} = "dpdk"
7
8SRC_URI = "git://github.com/qoriq-open-source/dpdk-extras.git;nobranch=1"
9SRCREV = "d17f3e065474a41e314ff73b9035e5b3dc021a28"
10
11S = "${WORKDIR}/git"
12
13DPAA_VER ?= "dpaa2"
14DPAA_VER_fsl-lsch2 = "dpaa"
15
16do_install() {
17 install -d ${D}/${bindir}/dpdk-example/extras
18
19 for file_suffix in xml sh; do
20 if [ "`ls ${S}/${DPAA_VER}/*.${file_suffix}`" != "" ]; then
21 install -m 755 ${S}/${DPAA_VER}/*.${file_suffix} ${D}/${bindir}/dpdk-example/extras
22 fi
23 done
24}
25
26PACKAGE_ARCH = "${MACHINE_ARCH}"
27COMPATIBLE_MACHINE = "(ls2080ardb|ls2084ardb|ls2088a|ls1043a|ls1046a|ls1088a)"