diff options
Diffstat (limited to 'recipes-downgrade/vulkan/vulkan-loader_1.3.275.0.imx.bb')
-rw-r--r-- | recipes-downgrade/vulkan/vulkan-loader_1.3.275.0.imx.bb | 43 |
1 files changed, 43 insertions, 0 deletions
diff --git a/recipes-downgrade/vulkan/vulkan-loader_1.3.275.0.imx.bb b/recipes-downgrade/vulkan/vulkan-loader_1.3.275.0.imx.bb new file mode 100644 index 00000000..7caed672 --- /dev/null +++ b/recipes-downgrade/vulkan/vulkan-loader_1.3.275.0.imx.bb | |||
@@ -0,0 +1,43 @@ | |||
1 | SUMMARY = "3D graphics and compute API common loader" | ||
2 | DESCRIPTION = "Vulkan is a new generation graphics and compute API \ | ||
3 | that provides efficient access to modern GPUs. These packages \ | ||
4 | provide only the common vendor-agnostic library loader, headers and \ | ||
5 | the vulkaninfo utility." | ||
6 | HOMEPAGE = "https://www.khronos.org/vulkan/" | ||
7 | BUGTRACKER = "https://github.com/KhronosGroup/Vulkan-Loader" | ||
8 | SECTION = "libs" | ||
9 | |||
10 | LICENSE = "Apache-2.0" | ||
11 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=7dbefed23242760aa3475ee42801c5ac" | ||
12 | SRC_URI = "git://github.com/KhronosGroup/Vulkan-Loader.git;branch=vulkan-sdk-1.3.275;protocol=https" | ||
13 | SRCREV = "00893b9a03e526aec2c5bf487521d16dfa435229" | ||
14 | |||
15 | S = "${WORKDIR}/git" | ||
16 | |||
17 | REQUIRED_DISTRO_FEATURES = "vulkan" | ||
18 | |||
19 | inherit cmake features_check pkgconfig | ||
20 | |||
21 | DEPENDS += "vulkan-headers" | ||
22 | |||
23 | EXTRA_OECMAKE = "\ | ||
24 | -DBUILD_TESTS=OFF \ | ||
25 | -DPYTHON_EXECUTABLE=${HOSTTOOLS_DIR}/python3 \ | ||
26 | -DASSEMBLER_WORKS=FALSE \ | ||
27 | -DVulkanHeaders_INCLUDE_DIR=${STAGING_INCDIR} \ | ||
28 | -DVulkanRegistry_DIR=${RECIPE_SYSROOT}/${datadir} \ | ||
29 | " | ||
30 | |||
31 | PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'wayland x11', d)}" | ||
32 | |||
33 | PACKAGECONFIG[x11] = "-DBUILD_WSI_XLIB_SUPPORT=ON -DBUILD_WSI_XCB_SUPPORT=ON, -DBUILD_WSI_XLIB_SUPPORT=OFF -DBUILD_WSI_XCB_SUPPORT=OFF, libxcb libx11 libxrandr" | ||
34 | PACKAGECONFIG[wayland] = "-DBUILD_WSI_WAYLAND_SUPPORT=ON, -DBUILD_WSI_WAYLAND_SUPPORT=OFF, wayland" | ||
35 | |||
36 | RRECOMMENDS:${PN} = "mesa-vulkan-drivers" | ||
37 | |||
38 | # These recipes need to be updated in lockstep with each other: | ||
39 | # glslang, vulkan-headers, vulkan-loader, vulkan-tools, spirv-headers, spirv-tools, | ||
40 | # vulkan-validation-layers, vulkan-utility-libraries. | ||
41 | # The tags versions should always be sdk-x.y.z, as this is what | ||
42 | # upstream considers a release. | ||
43 | UPSTREAM_CHECK_GITTAGREGEX = "sdk-(?P<pver>\d+(\.\d+)+)" | ||