summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/uefi/uefi_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/uefi/uefi_git.bb')
-rw-r--r--recipes-bsp/uefi/uefi_git.bb16
1 files changed, 10 insertions, 6 deletions
diff --git a/recipes-bsp/uefi/uefi_git.bb b/recipes-bsp/uefi/uefi_git.bb
index 4d08782b..8b63f501 100644
--- a/recipes-bsp/uefi/uefi_git.bb
+++ b/recipes-bsp/uefi/uefi_git.bb
@@ -11,15 +11,19 @@ SRCREV= "5b259f75decbc478bcab0612d79a58562bef1838"
11S = "${WORKDIR}/git" 11S = "${WORKDIR}/git"
12 12
13do_install () { 13do_install () {
14 install -d ${D}/uefi 14 if [ -d ${B}/${MACHINE} ]; then
15 cp -r ${B}/grub ${D}/uefi 15 install -d ${D}/uefi
16 cp -r ${B}/${MACHINE} ${D}/uefi 16 cp -r ${B}/grub ${D}/uefi
17 cp -r ${B}/${MACHINE} ${D}/uefi
18 fi
17} 19}
18 20
19do_deploy () { 21do_deploy () {
20 install -d ${DEPLOYDIR}/uefi 22 if [ -d ${B}/${MACHINE} ]; then
21 cp -r ${B}/grub ${DEPLOYDIR}/uefi 23 install -d ${DEPLOYDIR}/uefi
22 cp -r ${B}/${MACHINE} ${DEPLOYDIR}/uefi 24 cp -r ${B}/grub ${DEPLOYDIR}/uefi
25 cp -r ${B}/${MACHINE} ${DEPLOYDIR}/uefi
26 fi
23} 27}
24addtask deploy before do_build after do_install 28addtask deploy before do_build after do_install
25 29