summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/u-boot
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/u-boot')
-rw-r--r--recipes-bsp/u-boot/u-boot-fslc-mxsboot_2017.09.bb20
1 files changed, 12 insertions, 8 deletions
diff --git a/recipes-bsp/u-boot/u-boot-fslc-mxsboot_2017.09.bb b/recipes-bsp/u-boot/u-boot-fslc-mxsboot_2017.09.bb
index b67a53ce..533bfbf6 100644
--- a/recipes-bsp/u-boot/u-boot-fslc-mxsboot_2017.09.bb
+++ b/recipes-bsp/u-boot/u-boot-fslc-mxsboot_2017.09.bb
@@ -3,23 +3,27 @@ require u-boot-fslc-common_${PV}.inc
3DESCRIPTION = "U-boot bootloader mxsboot tool" 3DESCRIPTION = "U-boot bootloader mxsboot tool"
4SECTION = "bootloader" 4SECTION = "bootloader"
5 5
6DEPENDS_append = " openssl" 6DEPENDS = "openssl"
7 7
8PROVIDES = "u-boot-mxsboot" 8PROVIDES = "u-boot-mxsboot"
9 9
10EXTRA_OEMAKE = 'HOSTCC="${CC} ${CPPFLAGS}" HOSTLDFLAGS="-L${libdir} -L${base_libdir}" HOSTSTRIP=true CONFIG_MX28=y' 10EXTRA_OEMAKE_class-target = 'CROSS_COMPILE="${TARGET_PREFIX}" CC="${CC} ${CFLAGS} ${LDFLAGS}" HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" STRIP=true V=1 CONFIG_MX28=y'
11EXTRA_OEMAKE_class-native = 'CC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" STRIP=true V=1 CONFIG_MX28=y'
12EXTRA_OEMAKE_class-nativesdk = 'CROSS_COMPILE="${HOST_PREFIX}" CC="${CC} ${CFLAGS} ${LDFLAGS}" HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" STRIP=true V=1 CONFIG_MX28=y'
11 13
12do_configure () { 14do_compile () {
13 oe_runmake sandbox_defconfig 15 oe_runmake sandbox_defconfig
14}
15 16
16do_compile () { 17 # Disable CONFIG_CMD_LICENSE, license.h is not used by tools and
17 oe_runmake tools-only 18 # generating it requires bin2header tool, which for target build
19 # is built with target tools and thus cannot be executed on host.
20 sed -i "s/CONFIG_CMD_LICENSE=.*/# CONFIG_CMD_LICENSE is not set/" .config
21
22 oe_runmake cross_tools NO_SDL=1
18} 23}
19 24
20do_install () { 25do_install () {
21 install -d ${D}${bindir} 26 install -Dm 0755 tools/mxsboot ${D}${bindir}/uboot-mxsboot
22 install -m 0755 tools/mxsboot ${D}${bindir}/uboot-mxsboot
23 ln -sf uboot-mxsboot ${D}${bindir}/mxsboot 27 ln -sf uboot-mxsboot ${D}${bindir}/mxsboot
24} 28}
25 29