summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/u-boot
diff options
context:
space:
mode:
authorFabio Berton <fabio.berton@ossystems.com.br>2017-10-06 17:34:42 -0300
committerOtavio Salvador <otavio@ossystems.com.br>2017-10-06 17:40:52 -0300
commit483325b52ca0d276fa97191c3614ff396b08af75 (patch)
tree7009eb82657757cb703bbd9913865b1007c5e99a /recipes-bsp/u-boot
parent74194390c14d803f83e73555d06f743b61c5eaa3 (diff)
downloadmeta-freescale-483325b52ca0d276fa97191c3614ff396b08af75.tar.gz
u-boot-fslc-mxsboot: Rework recipe to build with U-Boot 2017.09
- Use the same EXTRA_OEMAKE and do_compile task that u-boot-mkimage from OE-Core - Rework do_install task - Recipe depends only of openssl, no need to append DEPENDS variable Signed-off-by: Fabio Berton <fabio.berton@ossystems.com.br> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-bsp/u-boot')
-rw-r--r--recipes-bsp/u-boot/u-boot-fslc-mxsboot_2017.09.bb20
1 files changed, 12 insertions, 8 deletions
diff --git a/recipes-bsp/u-boot/u-boot-fslc-mxsboot_2017.09.bb b/recipes-bsp/u-boot/u-boot-fslc-mxsboot_2017.09.bb
index b67a53ce..533bfbf6 100644
--- a/recipes-bsp/u-boot/u-boot-fslc-mxsboot_2017.09.bb
+++ b/recipes-bsp/u-boot/u-boot-fslc-mxsboot_2017.09.bb
@@ -3,23 +3,27 @@ require u-boot-fslc-common_${PV}.inc
3DESCRIPTION = "U-boot bootloader mxsboot tool" 3DESCRIPTION = "U-boot bootloader mxsboot tool"
4SECTION = "bootloader" 4SECTION = "bootloader"
5 5
6DEPENDS_append = " openssl" 6DEPENDS = "openssl"
7 7
8PROVIDES = "u-boot-mxsboot" 8PROVIDES = "u-boot-mxsboot"
9 9
10EXTRA_OEMAKE = 'HOSTCC="${CC} ${CPPFLAGS}" HOSTLDFLAGS="-L${libdir} -L${base_libdir}" HOSTSTRIP=true CONFIG_MX28=y' 10EXTRA_OEMAKE_class-target = 'CROSS_COMPILE="${TARGET_PREFIX}" CC="${CC} ${CFLAGS} ${LDFLAGS}" HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" STRIP=true V=1 CONFIG_MX28=y'
11EXTRA_OEMAKE_class-native = 'CC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" STRIP=true V=1 CONFIG_MX28=y'
12EXTRA_OEMAKE_class-nativesdk = 'CROSS_COMPILE="${HOST_PREFIX}" CC="${CC} ${CFLAGS} ${LDFLAGS}" HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" STRIP=true V=1 CONFIG_MX28=y'
11 13
12do_configure () { 14do_compile () {
13 oe_runmake sandbox_defconfig 15 oe_runmake sandbox_defconfig
14}
15 16
16do_compile () { 17 # Disable CONFIG_CMD_LICENSE, license.h is not used by tools and
17 oe_runmake tools-only 18 # generating it requires bin2header tool, which for target build
19 # is built with target tools and thus cannot be executed on host.
20 sed -i "s/CONFIG_CMD_LICENSE=.*/# CONFIG_CMD_LICENSE is not set/" .config
21
22 oe_runmake cross_tools NO_SDL=1
18} 23}
19 24
20do_install () { 25do_install () {
21 install -d ${D}${bindir} 26 install -Dm 0755 tools/mxsboot ${D}${bindir}/uboot-mxsboot
22 install -m 0755 tools/mxsboot ${D}${bindir}/uboot-mxsboot
23 ln -sf uboot-mxsboot ${D}${bindir}/mxsboot 27 ln -sf uboot-mxsboot ${D}${bindir}/mxsboot
24} 28}
25 29