summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/u-boot/u-boot-qoriq-fw-utils_2019.09.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/u-boot/u-boot-qoriq-fw-utils_2019.09.bb')
-rw-r--r--recipes-bsp/u-boot/u-boot-qoriq-fw-utils_2019.09.bb44
1 files changed, 44 insertions, 0 deletions
diff --git a/recipes-bsp/u-boot/u-boot-qoriq-fw-utils_2019.09.bb b/recipes-bsp/u-boot/u-boot-qoriq-fw-utils_2019.09.bb
new file mode 100644
index 00000000..7a8ad21b
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot-qoriq-fw-utils_2019.09.bb
@@ -0,0 +1,44 @@
1require u-boot-qoriq-common_${PV}.inc
2
3SUMMARY = "U-Boot bootloader fw_printenv/setenv utilities"
4DEPENDS = "mtd-utils bison-native"
5
6EXTRA_OEMAKE_class-target = 'CROSS_COMPILE=${TARGET_PREFIX} CC="${CC} ${CFLAGS} ${LDFLAGS}" HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" STRIP=true V=1'
7EXTRA_OEMAKE_class-cross = 'ARCH=${TARGET_ARCH} CC="${CC} ${CFLAGS} ${LDFLAGS}" STRIP=true V=1'
8
9inherit uboot-config
10
11do_compile () {
12 oe_runmake ${UBOOT_MACHINE}
13 oe_runmake envtools
14}
15
16do_install () {
17 install -d ${D}${base_sbindir}
18 install -d ${D}${sysconfdir}
19 install -m 755 ${S}/tools/env/fw_printenv ${D}${base_sbindir}/fw_printenv
20 install -m 755 ${S}/tools/env/fw_printenv ${D}${base_sbindir}/fw_setenv
21
22 if [ -e ${WORKDIR}/fw_env.config ]; then
23 install -m 0644 ${WORKDIR}/fw_env.config ${D}${sysconfdir}/fw_env.config
24 else
25 install -m 0644 ${S}/tools/env/fw_env.config ${D}${sysconfdir}/fw_env.config
26 fi
27}
28
29do_install_class-cross () {
30 install -d ${D}${bindir_cross}
31 install -m 755 ${S}/tools/env/fw_printenv ${D}${bindir_cross}/fw_printenv
32 install -m 755 ${S}/tools/env/fw_printenv ${D}${bindir_cross}/fw_setenv
33}
34
35SYSROOT_PREPROCESS_FUNCS_class-cross = "uboot_fw_utils_cross"
36uboot_fw_utils_cross() {
37 sysroot_stage_dir ${D}${bindir_cross} ${SYSROOT_DESTDIR}${bindir_cross}
38}
39
40PROVIDES += "u-boot-fw-utils"
41RPROVIDES_${PN} += "u-boot-fw-utils"
42
43PACKAGE_ARCH = "${MACHINE_ARCH}"
44BBCLASSEXTEND = "cross"