summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/u-boot/u-boot-fslc_2018.09.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/u-boot/u-boot-fslc_2018.09.bb')
-rw-r--r--recipes-bsp/u-boot/u-boot-fslc_2018.09.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/recipes-bsp/u-boot/u-boot-fslc_2018.09.bb b/recipes-bsp/u-boot/u-boot-fslc_2018.09.bb
new file mode 100644
index 00000000..6c391ad3
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot-fslc_2018.09.bb
@@ -0,0 +1,21 @@
1require recipes-bsp/u-boot/u-boot.inc
2require u-boot-fslc-common_${PV}.inc
3
4DESCRIPTION = "U-Boot based on mainline U-Boot used by FSL Community BSP in \
5order to provide support for some backported features and fixes, or because it \
6was submitted for revision and it takes some time to become part of a stable \
7version, or because it is not applicable for upstreaming."
8
9DEPENDS_append = " dtc-native bison-native"
10
11PROVIDES += "u-boot"
12
13# FIXME: Allow linking of 'tools' binaries with native libraries
14# used for generating the boot logo and other tools used
15# during the build process.
16EXTRA_OEMAKE += 'HOSTCC="${BUILD_CC} ${BUILD_CPPFLAGS}" \
17 HOSTLDFLAGS="${BUILD_LDFLAGS}" \
18 HOSTSTRIP=true'
19
20PACKAGE_ARCH = "${MACHINE_ARCH}"
21COMPATIBLE_MACHINE = "(mxs|mx5|mx6|mx7|vf|use-mainline-bsp)"