summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/imx-vpu/imx-vpu-11.09.02/obey-variables.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/imx-vpu/imx-vpu-11.09.02/obey-variables.patch')
-rw-r--r--recipes-bsp/imx-vpu/imx-vpu-11.09.02/obey-variables.patch27
1 files changed, 27 insertions, 0 deletions
diff --git a/recipes-bsp/imx-vpu/imx-vpu-11.09.02/obey-variables.patch b/recipes-bsp/imx-vpu/imx-vpu-11.09.02/obey-variables.patch
new file mode 100644
index 00000000..13f61b27
--- /dev/null
+++ b/recipes-bsp/imx-vpu/imx-vpu-11.09.02/obey-variables.patch
@@ -0,0 +1,27 @@
1Obey CFLAGS, LDFLAGS
2
3Signed-off-by: Christopher Larson <chris_larson@mentor.com>
4Upstream-status: Pending
5
6--- imx-vpu-11.09.02.orig/vpu/Makefile 2014-09-02 13:14:50.862005896 -0700
7+++ imx-vpu-11.09.02/vpu/Makefile 2014-09-02 13:15:15.018153222 -0700
8@@ -1,5 +1,6 @@
9 CC ?=$(CROSS_COMPILE)gcc
10 AR ?=$(CROSS_COMPILE)ar
11+CFLAGS ?= -O2
12
13 # list of platforms which want this test case
14 INCLUDE_LIST:= IMX27ADS IMX51 IMX53 IMX6Q
15@@ -33,10 +34,10 @@
16 endif
17
18 %.o: %.c
19- $(CC) -D$(PLATFORM) -Wall -O2 -fPIC -c $^ -o $@
20+ $(CC) -D$(PLATFORM) -Wall -fPIC $(CFLAGS) -c $^ -o $@
21
22 $(LIBNAME).so.$(SONAMEVERSION): $(OBJ)
23- $(CC) -shared -nostartfiles -Wl,-soname,$@ $^ -o $@
24+ $(CC) -shared -nostartfiles -Wl,-soname,$@ $^ -o $@ $(LDFLAGS)
25
26 $(LIBNAME).so: $(LIBNAME).so.$(SONAMEVERSION)
27 ln -s $< $@