summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.6.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.6.0.bb')
-rw-r--r--recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.6.0.bb33
1 files changed, 0 insertions, 33 deletions
diff --git a/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.6.0.bb b/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.6.0.bb
deleted file mode 100644
index 609d6928..00000000
--- a/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.6.0.bb
+++ /dev/null
@@ -1,33 +0,0 @@
1# Copyright 2017 NXP
2
3DESCRIPTION = "i.MX Hantro VPU library"
4LICENSE = "Proprietary"
5LIC_FILES_CHKSUM = "file://COPYING;md5=08fd295cce89b0a9c74b9b83ed74f671"
6
7DEPENDS = "virtual/kernel"
8
9PROVIDES = "virtual/imxvpu"
10
11SRC_URI = "${FSL_MIRROR}/${PN}-${PV}.bin;fsl-eula=true \
12 file://0001-Fix-ion.h-header-inclusion-to-be-standard.patch \
13"
14
15SRC_URI[md5sum] = "09ec833586afb5f194ce0202da925ed6"
16SRC_URI[sha256sum] = "cbc648e41f005aad209f74c9e5dd346138dca12efeb7b27e471de7474c4da302"
17
18inherit fsl-eula-unpack
19
20PARALLEL_MAKE="-j 1"
21
22do_compile () {
23 oe_runmake CROSS_COMPILE="${HOST_PREFIX}" LINUX_KERNEL_ROOT="${STAGING_KERNEL_DIR}" SDKTARGETSYSROOT="${STAGING_DIR_TARGET}" all
24}
25
26do_install () {
27 oe_runmake DEST_DIR="${D}" install
28}
29
30FILES_${PN} += "/unit_tests"
31
32PACKAGE_ARCH = "${MACHINE_ARCH}"
33COMPATIBLE_MACHINE = "(mx8mq)"