summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro/0001-Get-i.MX-custom-headers-from-usr-include-imx.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/imx-vpu-hantro/imx-vpu-hantro/0001-Get-i.MX-custom-headers-from-usr-include-imx.patch')
-rw-r--r--recipes-bsp/imx-vpu-hantro/imx-vpu-hantro/0001-Get-i.MX-custom-headers-from-usr-include-imx.patch49
1 files changed, 49 insertions, 0 deletions
diff --git a/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro/0001-Get-i.MX-custom-headers-from-usr-include-imx.patch b/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro/0001-Get-i.MX-custom-headers-from-usr-include-imx.patch
new file mode 100644
index 00000000..a41641df
--- /dev/null
+++ b/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro/0001-Get-i.MX-custom-headers-from-usr-include-imx.patch
@@ -0,0 +1,49 @@
1From a277191d6e7d775b1c081f8b25734f6f962ade14 Mon Sep 17 00:00:00 2001
2From: Tom Hochstein <tom.hochstein@nxp.com>
3Date: Thu, 4 Oct 2018 10:34:00 -0500
4Subject: [PATCH] Get i.MX custom headers from /usr/include/imx
5
6Upstream-Status: Pending
7
8Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
9---
10 Makefile_G1G2 | 5 ++---
11 Makefile_H1 | 3 +--
12 2 files changed, 3 insertions(+), 5 deletions(-)
13
14diff --git a/Makefile_G1G2 b/Makefile_G1G2
15index caab40f..5b55a8b 100755
16--- a/Makefile_G1G2
17+++ b/Makefile_G1G2
18@@ -6,12 +6,11 @@ SOURCE_ROOT = decoder_sw/software
19 OMX_ROOT = openmax_il
20
21 INCLUDE_HEADERS = -I./decoder_sw -I$(SOURCE_ROOT)/source/inc -I$(SOURCE_ROOT)/source/hevc \
22- -I$(SOURCE_ROOT)/source/config -I$(SOURCE_ROOT)/source/dwl -I$(SOURCE_ROOT)/source/common -I$(SOURCE_ROOT)/source/vp9 \
23- -I$(SDKTARGETSYSROOT)/usr/imx/include
24+ -I$(SOURCE_ROOT)/source/config -I$(SOURCE_ROOT)/source/dwl -I$(SOURCE_ROOT)/source/common -I$(SOURCE_ROOT)/source/vp9
25
26 INCLUDE_HEADERS += -I$(SOURCE_ROOT)/linux/memalloc
27 #INCLUDE_HEADERS += -I$(SOURCE_ROOT)/linux/ldriver
28-INCLUDE_HEADERS += -I$(LINUX_KERNEL_ROOT)/include/uapi -I$(LINUX_KERNEL_ROOT)/include
29+INCLUDE_HEADERS += -I$(SDKTARGETSYSROOT)/usr/include/imx
30
31 CFLAGS += -DDEC_MODULE_PATH=\"/dev/mxc_hantro\" -DUSE_FAKE_RFC_TABLE -DFIFO_DATATYPE=void* -DNDEBUG -DDOWN_SCALER \
32 -DUSE_EXTERNAL_BUFFER -DUSE_FAST_EC -DUSE_VP9_EC -DGET_FREE_BUFFER_NON_BLOCK \
33diff --git a/Makefile_H1 b/Makefile_H1
34index 9ca1aa9..237f53a 100755
35--- a/Makefile_H1
36+++ b/Makefile_H1
37@@ -17,8 +17,7 @@ ENV += -DMEMALLOC_MODULE_PATH=\\\"/dev/ion\\\"
38 #ENV += -DSDRAM_LM_BASE=0x00000000
39 ENV += -DEWL_NO_HW_TIMEOUT
40 ENV += -DUSE_ION
41-ENV += -I$(LINUX_KERNEL_ROOT)/include/uapi -I$(LINUX_KERNEL_ROOT)/include
42-ENV += -I$(SDKTARGETSYSROOT)/usr/imx/include
43+ENV += -I$(SDKTARGETSYSROOT)/usr/include/imx
44
45 LIBENCNAME = libcodec_enc
46 LIBSENC = -L./ -lhantro_h1 -lpthread
47--
482.7.4
49