summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro/0001-Fix-ion.h-header-inclusion-to-be-standard.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/imx-vpu-hantro/imx-vpu-hantro/0001-Fix-ion.h-header-inclusion-to-be-standard.patch')
-rw-r--r--recipes-bsp/imx-vpu-hantro/imx-vpu-hantro/0001-Fix-ion.h-header-inclusion-to-be-standard.patch41
1 files changed, 41 insertions, 0 deletions
diff --git a/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro/0001-Fix-ion.h-header-inclusion-to-be-standard.patch b/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro/0001-Fix-ion.h-header-inclusion-to-be-standard.patch
new file mode 100644
index 00000000..e7b23f7e
--- /dev/null
+++ b/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro/0001-Fix-ion.h-header-inclusion-to-be-standard.patch
@@ -0,0 +1,41 @@
1From 872c82e7cbb9a0a0e761e8ac70fc28e19a55b4c3 Mon Sep 17 00:00:00 2001
2From: Gary Bisson <gary.bisson@boundarydevices.com>
3Date: Thu, 12 Jul 2018 11:38:28 +0200
4Subject: [PATCH] Fix ion.h header inclusion to be standard
5
6NXP "solution" was to manually copy the header to include/linux.
7Let's point the Makefile to the proper (mainline) location instead:
8https://elixir.bootlin.com/linux/v4.17/source/drivers/staging/android/uapi/ion.h
9
10Signed-off-by: Gary Bisson <gary.bisson@boundarydevices.com>
11---
12 Makefile | 2 ++
13 decoder_sw/software/linux/dwl/dwl_linux.c | 2 +-
14 2 files changed, 3 insertions(+), 1 deletion(-)
15
16Index: imx-vpu-hantro-1.7.0/decoder_sw/software/linux/dwl/dwl_linux.c
17===================================================================
18--- imx-vpu-hantro-1.7.0.orig/decoder_sw/software/linux/dwl/dwl_linux.c
19+++ imx-vpu-hantro-1.7.0/decoder_sw/software/linux/dwl/dwl_linux.c
20@@ -41,7 +41,7 @@
21 #include "dwl.h"
22 #include <linux/hantrodec.h>
23 #ifdef USE_ION
24-#include <linux/ion.h>
25+#include <ion.h>
26 #ifdef ANDROID
27 #include <linux/mxc_ion.h>
28 #endif
29Index: imx-vpu-hantro-1.7.0/Makefile_G1G2
30===================================================================
31--- imx-vpu-hantro-1.7.0.orig/Makefile_G1G2
32+++ imx-vpu-hantro-1.7.0/Makefile_G1G2
33@@ -11,6 +11,8 @@ INCLUDE_HEADERS = -I./decoder_sw -I$(SOU
34 INCLUDE_HEADERS += -I$(SOURCE_ROOT)/linux/memalloc
35 #INCLUDE_HEADERS += -I$(SOURCE_ROOT)/linux/ldriver
36 INCLUDE_HEADERS += -I$(LINUX_KERNEL_ROOT)/include/uapi -I$(LINUX_KERNEL_ROOT)/include
37+# ION header location
38+INCLUDE_HEADERS += -I$(LINUX_KERNEL_ROOT)/drivers/staging/android/uapi
39
40 CFLAGS += -DDEC_MODULE_PATH=\"/dev/mxc_hantro\" -DUSE_FAKE_RFC_TABLE -DFIFO_DATATYPE=void* -DNDEBUG -DDOWN_SCALER \
41 -DUSE_EXTERNAL_BUFFER -DUSE_FAST_EC -DUSE_VP9_EC -DGET_FREE_BUFFER_NON_BLOCK \