summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro/0001-Fix-ion.h-header-inclusion-to-be-standard.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/imx-vpu-hantro/imx-vpu-hantro/0001-Fix-ion.h-header-inclusion-to-be-standard.patch')
-rw-r--r--recipes-bsp/imx-vpu-hantro/imx-vpu-hantro/0001-Fix-ion.h-header-inclusion-to-be-standard.patch74
1 files changed, 0 insertions, 74 deletions
diff --git a/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro/0001-Fix-ion.h-header-inclusion-to-be-standard.patch b/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro/0001-Fix-ion.h-header-inclusion-to-be-standard.patch
deleted file mode 100644
index 27731004..00000000
--- a/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro/0001-Fix-ion.h-header-inclusion-to-be-standard.patch
+++ /dev/null
@@ -1,74 +0,0 @@
1From cf67cfecc01538e32cd99e3ca00ff0e6145079ce Mon Sep 17 00:00:00 2001
2From: Yuqing Zhu <carol.zhu@nxp.com>
3Date: Thu, 27 Sep 2018 15:34:11 +0800
4Subject: [PATCH] imx-vpu-hantro: Fix ion.h header inclusion to be standard
5
6NXP "solution" was to manually copy the header to include/linux.
7Let's point the Makefile to the proper (mainline) location instead:
8https://elixir.bootlin.com/linux/v4.17/source/drivers/staging/android/uapi/ion.h
9
10Signed-off-by: Yuqing Zhu <carol.zhu@nxp.com>
11---
12 Makefile_G1G2 | 3 +++
13 Makefile_H1 | 3 +++
14 decoder_sw/software/linux/dwl/dwl_linux.c | 2 +-
15 h1_encoder/software/linux_reference/ewl/ewl_x280_common.c | 2 +-
16 4 files changed, 8 insertions(+), 2 deletions(-)
17
18diff --git a/Makefile_G1G2 b/Makefile_G1G2
19index caab40f..29866a4 100755
20--- a/Makefile_G1G2
21+++ b/Makefile_G1G2
22@@ -13,6 +13,9 @@ INCLUDE_HEADERS += -I$(SOURCE_ROOT)/linux/memalloc
23 #INCLUDE_HEADERS += -I$(SOURCE_ROOT)/linux/ldriver
24 INCLUDE_HEADERS += -I$(LINUX_KERNEL_ROOT)/include/uapi -I$(LINUX_KERNEL_ROOT)/include
25
26+# ION header location
27+INCLUDE_HEADERS += -I$(LINUX_KERNEL_ROOT)/drivers/staging/android/uapi
28+
29 CFLAGS += -DDEC_MODULE_PATH=\"/dev/mxc_hantro\" -DUSE_FAKE_RFC_TABLE -DFIFO_DATATYPE=void* -DNDEBUG -DDOWN_SCALER \
30 -DUSE_EXTERNAL_BUFFER -DUSE_FAST_EC -DUSE_VP9_EC -DGET_FREE_BUFFER_NON_BLOCK \
31 -DDEC_X170_OUTPUT_FORMAT=0 -DDEC_X170_TIMEOUT_LENGTH=-1 -DENABLE_HEVC_SUPPORT \
32diff --git a/Makefile_H1 b/Makefile_H1
33index 9ca1aa9..56b4332 100755
34--- a/Makefile_H1
35+++ b/Makefile_H1
36@@ -20,6 +20,9 @@ ENV += -DUSE_ION
37 ENV += -I$(LINUX_KERNEL_ROOT)/include/uapi -I$(LINUX_KERNEL_ROOT)/include
38 ENV += -I$(SDKTARGETSYSROOT)/usr/imx/include
39
40+# ION header location
41+ENV += -I$(LINUX_KERNEL_ROOT)/drivers/staging/android/uapi
42+
43 LIBENCNAME = libcodec_enc
44 LIBSENC = -L./ -lhantro_h1 -lpthread
45
46diff --git a/decoder_sw/software/linux/dwl/dwl_linux.c b/decoder_sw/software/linux/dwl/dwl_linux.c
47index 0899596..f2e1229 100755
48--- a/decoder_sw/software/linux/dwl/dwl_linux.c
49+++ b/decoder_sw/software/linux/dwl/dwl_linux.c
50@@ -41,7 +41,7 @@
51 #include "dwl.h"
52 #include <linux/hantrodec.h>
53 #ifdef USE_ION
54-#include <linux/ion.h>
55+#include <ion.h>
56 #include <linux/dma-buf.h>
57 #include <linux/version.h>
58 #ifdef ANDROID
59diff --git a/h1_encoder/software/linux_reference/ewl/ewl_x280_common.c b/h1_encoder/software/linux_reference/ewl/ewl_x280_common.c
60index 620c978..82b4836 100755
61--- a/h1_encoder/software/linux_reference/ewl/ewl_x280_common.c
62+++ b/h1_encoder/software/linux_reference/ewl/ewl_x280_common.c
63@@ -49,7 +49,7 @@
64
65 #include "linux/hx280enc.h"
66 #ifdef USE_ION
67-#include <linux/ion.h>
68+#include <ion.h>
69 #include <linux/dma-buf.h>
70 #include <linux/version.h>
71 #ifdef ANDROID
72--
731.9.1
74