summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/imx-bootlets/imx-bootlets_10.12.01.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/imx-bootlets/imx-bootlets_10.12.01.bb')
-rw-r--r--recipes-bsp/imx-bootlets/imx-bootlets_10.12.01.bb79
1 files changed, 79 insertions, 0 deletions
diff --git a/recipes-bsp/imx-bootlets/imx-bootlets_10.12.01.bb b/recipes-bsp/imx-bootlets/imx-bootlets_10.12.01.bb
new file mode 100644
index 00000000..6084f169
--- /dev/null
+++ b/recipes-bsp/imx-bootlets/imx-bootlets_10.12.01.bb
@@ -0,0 +1,79 @@
1DESCRIPTION = "i.MXS boot streams"
2LICENSE = "GPL-2.0"
3LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
4
5PR = "r5"
6
7SRC_URI = "http://download.ossystems.com.br/bsp/freescale/source/imx-bootlets-src-${PV}.tar.gz \
8 file://linux-fix-paths.patch \
9 file://linux_prep-fix-cmdlines.patch \
10 file://add-command-script-for-barebox.patch"
11
12SRC_URI[md5sum] = "cf0ab3822dca694b930a051501c1d0e4"
13SRC_URI[sha256sum] = "63f6068ae36884adef4259bbb1fe2591755718f22c46d0a59d854883dfab1ffc"
14
15S = "${WORKDIR}/imx-bootlets-src-${PV}"
16
17inherit deploy
18
19# Disable parallel building or it may fail to build.
20PARALLEL_MAKE = ""
21
22EXTRA_OEMAKE = "CROSS_COMPILE=${TARGET_PREFIX}"
23
24# Ensure machine defines the IMXBOOTLETS_MACHINE
25python () {
26 if not d.getVar("IMXBOOTLETS_MACHINE", True):
27 PN = d.getVar("PN", True)
28 FILE = os.path.basename(d.getVar("FILE", True))
29 bb.debug(1, "To build %s, see %s for instructions on \
30 setting up your machine config" % (PN, FILE))
31 raise bb.parse.SkipPackage("because IMXBOOTLETS_MACHINE is not set")
32}
33
34do_configure () {
35 # Use machine specific binaries
36 sed 's,@MACHINE@,${MACHINE},g;s,@DTB@,-dtb,g' < linux.bd > linux.bd-dtb
37 sed -i 's,@MACHINE@,${MACHINE},g;s,@DTB@,,g' linux.bd
38 sed -i 's,@MACHINE@,${MACHINE},g' barebox_ivt.bd
39}
40
41do_compile () {
42 oe_runmake BOARD=${IMXBOOTLETS_MACHINE} linux_prep \
43 boot_prep \
44 power_prep \
45 'CC=${TARGET_PREFIX}gcc --sysroot="${STAGING_DIR_TARGET}"' \
46 'LD=${TARGET_PREFIX}ld --sysroot="${STAGING_DIR_TARGET}"'
47}
48
49do_install () {
50 install -d ${D}/boot/
51 install -m 644 boot_prep/boot_prep power_prep/power_prep \
52 linux_prep/output-target/linux_prep \
53 linux.bd linux.bd-dtb \
54 barebox_ivt.bd \
55 ${D}/boot
56}
57
58FILES_${PN} = "/boot"
59
60do_deploy () {
61 install -d ${DEPLOYDIR}
62
63 for f in boot_prep/boot_prep \
64 power_prep/power_prep \
65 linux_prep/output-target/linux_prep \
66 barebox_ivt.bd \
67 linux.bd linux.bd-dtb; do
68 full_name="imx-bootlets-`basename $f`-${MACHINE}-${PV}-${PR}"
69 symlink_name="imx-bootlets-`basename $f`-${MACHINE}"
70
71 install -m 644 ${S}/$f ${DEPLOYDIR}/$full_name
72 (cd ${DEPLOYDIR} ; rm -f $symlink_name ; ln -sf $full_name $symlink_name)
73 done
74}
75
76addtask deploy before do_build after do_compile
77
78PACKAGE_ARCH = "${MACHINE_ARCH}"
79COMPATIBLE_MACHINE = "(mxs)"