summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/imx-atf/imx-atf_2.6.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/imx-atf/imx-atf_2.6.bb')
-rw-r--r--recipes-bsp/imx-atf/imx-atf_2.6.bb9
1 files changed, 8 insertions, 1 deletions
diff --git a/recipes-bsp/imx-atf/imx-atf_2.6.bb b/recipes-bsp/imx-atf/imx-atf_2.6.bb
index 95258247..194ef935 100644
--- a/recipes-bsp/imx-atf/imx-atf_2.6.bb
+++ b/recipes-bsp/imx-atf/imx-atf_2.6.bb
@@ -18,7 +18,11 @@ S = "${WORKDIR}/git"
18 18
19inherit deploy 19inherit deploy
20 20
21ATF_PLATFORM ??= "INVALID" 21ATF_PLATFORM ??= "INVALID"
22
23# FIXME: We should return INVALID here but currently only i.MX8M has support to override the UART
24# base address in source code.
25ATF_BOOT_UART_BASE ?= ""
22 26
23EXTRA_OEMAKE += " \ 27EXTRA_OEMAKE += " \
24 CROSS_COMPILE="${TARGET_PREFIX}" \ 28 CROSS_COMPILE="${TARGET_PREFIX}" \
@@ -48,6 +52,9 @@ EXTRA_OEMAKE += 'LD="${@remove_options_tail(d.getVar('LD'))}"'
48 52
49EXTRA_OEMAKE += 'CC="${@remove_options_tail(d.getVar('CC'))}"' 53EXTRA_OEMAKE += 'CC="${@remove_options_tail(d.getVar('CC'))}"'
50 54
55# Set the UART to use during the boot.
56EXTRA_OEMAKE += 'IMX_BOOT_UART_BASE=${ATF_BOOT_UART_BASE}'
57
51do_configure[noexec] = "1" 58do_configure[noexec] = "1"
52 59
53do_compile() { 60do_compile() {