summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/imx-atf/imx-atf_2.10.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/imx-atf/imx-atf_2.10.bb')
-rw-r--r--recipes-bsp/imx-atf/imx-atf_2.10.bb6
1 files changed, 4 insertions, 2 deletions
diff --git a/recipes-bsp/imx-atf/imx-atf_2.10.bb b/recipes-bsp/imx-atf/imx-atf_2.10.bb
index 14ed1252..04826b4c 100644
--- a/recipes-bsp/imx-atf/imx-atf_2.10.bb
+++ b/recipes-bsp/imx-atf/imx-atf_2.10.bb
@@ -9,7 +9,7 @@ PV .= "+git${SRCPV}"
9 9
10SRC_URI = "git://github.com/nxp-imx/imx-atf.git;protocol=https;branch=${SRCBRANCH}" 10SRC_URI = "git://github.com/nxp-imx/imx-atf.git;protocol=https;branch=${SRCBRANCH}"
11SRCBRANCH = "lf_v2.10" 11SRCBRANCH = "lf_v2.10"
12SRCREV = "49143a1701d9ccd3239e3f95f3042897ca889ea8" 12SRCREV = "28affcae957cb8194917b5246276630f9e6343e1"
13 13
14S = "${WORKDIR}/git" 14S = "${WORKDIR}/git"
15 15
@@ -48,7 +48,9 @@ def remove_options_tail (in_string):
48 from itertools import takewhile 48 from itertools import takewhile
49 return ' '.join(takewhile(lambda x: not x.startswith('-'), in_string.split(' '))) 49 return ' '.join(takewhile(lambda x: not x.startswith('-'), in_string.split(' ')))
50 50
51EXTRA_OEMAKE += 'LD="${@remove_options_tail(d.getVar('LD'))}.bfd"' 51# LD can have linker suffix in its name e.g. aarch64-yoe-linux-ld.lld so we need to
52# drop .lld as well along with options from LD
53EXTRA_OEMAKE += 'LD="${HOST_PREFIX}ld.bfd"'
52 54
53EXTRA_OEMAKE += 'CC="${@remove_options_tail(d.getVar('CC'))}"' 55EXTRA_OEMAKE += 'CC="${@remove_options_tail(d.getVar('CC'))}"'
54 56