summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/firmware-imx/imx-boot-firmware-files_8.22.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/firmware-imx/imx-boot-firmware-files_8.22.bb')
-rw-r--r--recipes-bsp/firmware-imx/imx-boot-firmware-files_8.22.bb61
1 files changed, 61 insertions, 0 deletions
diff --git a/recipes-bsp/firmware-imx/imx-boot-firmware-files_8.22.bb b/recipes-bsp/firmware-imx/imx-boot-firmware-files_8.22.bb
new file mode 100644
index 00000000..24619859
--- /dev/null
+++ b/recipes-bsp/firmware-imx/imx-boot-firmware-files_8.22.bb
@@ -0,0 +1,61 @@
1# Copyright (C) 2018-2023 NXP
2SUMMARY = "Freescale i.MX Firmware files used for boot"
3
4require firmware-imx-${PV}.inc
5
6inherit deploy nopackages
7
8do_install[noexec] = "1"
9
10DEPLOY_FOR = ""
11DEPLOY_FOR:mx8-generic-bsp = "mx8"
12DEPLOY_FOR:mx8m-generic-bsp = "mx8m"
13DEPLOY_FOR:mx9-generic-bsp = "mx9"
14
15deploy_for_mx8() {
16 # Cadence HDMI
17 install -m 0644 ${S}/firmware/hdmi/cadence/hdmitxfw.bin ${DEPLOYDIR}
18 install -m 0644 ${S}/firmware/hdmi/cadence/hdmirxfw.bin ${DEPLOYDIR}
19 install -m 0644 ${S}/firmware/hdmi/cadence/dpfw.bin ${DEPLOYDIR}
20}
21
22deploy_for_mx8m() {
23 # Synopsys DDR
24 for ddr_firmware in ${DDR_FIRMWARE_NAME}; do
25 install -m 0644 ${S}/firmware/ddr/synopsys/${ddr_firmware} ${DEPLOYDIR}
26 done
27
28 # Cadence DP and HDMI
29 install -m 0644 ${S}/firmware/hdmi/cadence/signed_dp_imx8m.bin ${DEPLOYDIR}
30 install -m 0644 ${S}/firmware/hdmi/cadence/signed_hdmi_imx8m.bin ${DEPLOYDIR}
31}
32
33
34deploy_for_mx9() {
35 # Synopsys DDR
36 for ddr_firmware in ${DDR_FIRMWARE_NAME}; do
37 install -m 0644 ${S}/firmware/ddr/synopsys/${ddr_firmware} ${DEPLOYDIR}
38 done
39}
40
41python () {
42 # Manually add the required functions as dependencies otherwise they won't be included in the
43 # final run script.
44 deploy_for = d.getVar('DEPLOY_FOR', True).split()
45 for soc in deploy_for:
46 d.appendVarFlag('do_deploy', 'vardeps', ' deploy_for_%s' % soc)
47}
48
49do_deploy () {
50 for soc in ${DEPLOY_FOR}; do
51 bbnote "Running deploy for $soc"
52 deploy_for_$soc
53 done
54}
55
56addtask deploy after do_install before do_build
57
58PACKAGE_ARCH = "${MACHINE_SOCARCH}"
59
60COMPATIBLE_MACHINE = "(mx8-generic-bsp|mx9-generic-bsp)"
61COMPATIBLE_MACHINE:mx8x-generic-bsp = "(^$)"