summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/firmware-imx/imx-boot-firmware-files_8.18.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/firmware-imx/imx-boot-firmware-files_8.18.bb')
-rw-r--r--recipes-bsp/firmware-imx/imx-boot-firmware-files_8.18.bb62
1 files changed, 62 insertions, 0 deletions
diff --git a/recipes-bsp/firmware-imx/imx-boot-firmware-files_8.18.bb b/recipes-bsp/firmware-imx/imx-boot-firmware-files_8.18.bb
new file mode 100644
index 00000000..d4408cf1
--- /dev/null
+++ b/recipes-bsp/firmware-imx/imx-boot-firmware-files_8.18.bb
@@ -0,0 +1,62 @@
1# Copyright (C) 2018-2020 NXP
2SUMMARY = "Freescale i.MX firmware for 8 family"
3DESCRIPTION = "Freescale i.MX firmware for 8 family"
4
5require firmware-imx-${PV}.inc
6
7inherit deploy nopackages
8
9do_install[noexec] = "1"
10
11DEPLOY_FOR = ""
12DEPLOY_FOR:mx8-generic-bsp = "mx8"
13DEPLOY_FOR:mx8m-generic-bsp = "mx8 mx8m"
14DEPLOY_FOR:mx9-generic-bsp = "mx9"
15
16deploy_for_mx8() {
17 # Cadence HDMI
18 install -m 0644 ${S}/firmware/hdmi/cadence/hdmitxfw.bin ${DEPLOYDIR}
19 install -m 0644 ${S}/firmware/hdmi/cadence/hdmirxfw.bin ${DEPLOYDIR}
20 install -m 0644 ${S}/firmware/hdmi/cadence/dpfw.bin ${DEPLOYDIR}
21}
22
23deploy_for_mx8m() {
24 # Synopsys DDR
25 for ddr_firmware in ${DDR_FIRMWARE_NAME}; do
26 install -m 0644 ${S}/firmware/ddr/synopsys/${ddr_firmware} ${DEPLOYDIR}
27 done
28
29 # Cadence DP and HDMI
30 install -m 0644 ${S}/firmware/hdmi/cadence/signed_dp_imx8m.bin ${DEPLOYDIR}
31 install -m 0644 ${S}/firmware/hdmi/cadence/signed_hdmi_imx8m.bin ${DEPLOYDIR}
32}
33
34
35deploy_for_mx9() {
36 # Synopsys DDR
37 for ddr_firmware in ${DDR_FIRMWARE_NAME}; do
38 install -m 0644 ${S}/firmware/ddr/synopsys/${ddr_firmware} ${DEPLOYDIR}
39 done
40}
41
42python () {
43 # Manually add the required functions as dependencies otherwise they won't be included in the
44 # final run script.
45 deploy_for = d.getVar('DEPLOY_FOR', True).split()
46 for soc in deploy_for:
47 d.appendVarFlag('do_deploy', 'vardeps', ' deploy_for_%s' % soc)
48}
49
50do_deploy () {
51 for soc in ${DEPLOY_FOR}; do
52 bbnote "Running deploy for $soc"
53 deploy_for_$soc
54 done
55}
56
57addtask deploy after do_install before do_build
58
59PACKAGE_ARCH = "${MACHINE_SOCARCH}"
60
61COMPATIBLE_MACHINE = "(mx8-generic-bsp|mx9-generic-bsp)"
62COMPATIBLE_MACHINE:mx8x-generic-bsp = "(^$)"