summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/firmware-imx/firmware-imx-8_8.18.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/firmware-imx/firmware-imx-8_8.18.bb')
-rw-r--r--recipes-bsp/firmware-imx/firmware-imx-8_8.18.bb39
1 files changed, 0 insertions, 39 deletions
diff --git a/recipes-bsp/firmware-imx/firmware-imx-8_8.18.bb b/recipes-bsp/firmware-imx/firmware-imx-8_8.18.bb
deleted file mode 100644
index 588d45ee..00000000
--- a/recipes-bsp/firmware-imx/firmware-imx-8_8.18.bb
+++ /dev/null
@@ -1,39 +0,0 @@
1# Copyright (C) 2018-2020 NXP
2SUMMARY = "Freescale i.MX firmware for 8 family"
3DESCRIPTION = "Freescale i.MX firmware for 8 family"
4
5require firmware-imx-${PV}.inc
6
7inherit deploy nopackages
8
9do_install[noexec] = "1"
10
11SOC_FAMILY = "INVALID"
12SOC_FAMILY:mx8-generic-bsp = "mx8"
13SOC_FAMILY:mx9-generic-bsp = "mx9"
14
15deploy_mx8() {
16 # Cadence HDMI
17 install -m 0644 ${S}/firmware/hdmi/cadence/hdmitxfw.bin ${DEPLOYDIR}
18 install -m 0644 ${S}/firmware/hdmi/cadence/hdmirxfw.bin ${DEPLOYDIR}
19 install -m 0644 ${S}/firmware/hdmi/cadence/dpfw.bin ${DEPLOYDIR}
20}
21
22deploy_mx9() {
23 # Synopsys DDR
24 for ddr_firmware in ${DDR_FIRMWARE_NAME}; do
25 install -m 0644 ${S}/firmware/ddr/synopsys/${ddr_firmware} ${DEPLOYDIR}
26 done
27}
28
29do_deploy() {
30 deploy_${SOC_FAMILY}
31}
32
33addtask deploy after do_install before do_build
34
35PACKAGE_ARCH = "${MACHINE_SOCARCH}"
36
37COMPATIBLE_MACHINE = "(mx8-generic-bsp|mx9-generic-bsp)"
38COMPATIBLE_MACHINE:mx8m-generic-bsp = "(^$)"
39COMPATIBLE_MACHINE:mx8x-generic-bsp = "(^$)"