summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/elftosb/elftosb_10.12.01.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/elftosb/elftosb_10.12.01.bb')
-rw-r--r--recipes-bsp/elftosb/elftosb_10.12.01.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/recipes-bsp/elftosb/elftosb_10.12.01.bb b/recipes-bsp/elftosb/elftosb_10.12.01.bb
new file mode 100644
index 00000000..2cef1f6a
--- /dev/null
+++ b/recipes-bsp/elftosb/elftosb_10.12.01.bb
@@ -0,0 +1,22 @@
1# Copyright (C) 2011, 2012 Freescale
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4DESCRIPTION = "Helper utility for freescale imx platforms"
5LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://COPYING;md5=172ede34353056ebec7a597d8459f029"
7SECTION = "bootloader"
8PR = "r4"
9BBCLASSEXTEND = "native nativesdk"
10
11SRC_URI = "http://repository.timesys.com/buildsources/e/elftosb/elftosb-${PV}/elftosb-${PV}.tar.gz \
12 file://cross-build.patch \
13 file://don-t-use-full-path-for-headers.patch"
14SRC_URI[md5sum] = "e8005d606c1e0bb3507c82f6eceb3056"
15SRC_URI[sha256sum] = "77bb6981620f7575b87d136d94c7daa88dd09195959cc75fc18b138369ecd42b"
16
17do_install() {
18 install -d ${D}${bindir}
19 install ${S}/bld/linux/elftosb ${D}${bindir}
20 install ${S}/bld/linux/keygen ${D}${bindir}
21 install ${S}/bld/linux/sbtool ${D}${bindir}
22}