summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/change-file-endianess/change-file-endianess.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/change-file-endianess/change-file-endianess.bb')
-rw-r--r--recipes-bsp/change-file-endianess/change-file-endianess.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/recipes-bsp/change-file-endianess/change-file-endianess.bb b/recipes-bsp/change-file-endianess/change-file-endianess.bb
new file mode 100644
index 00000000..2ad8c588
--- /dev/null
+++ b/recipes-bsp/change-file-endianess/change-file-endianess.bb
@@ -0,0 +1,23 @@
1DESCRIPTION = "provides the tcl script for endian swap"
2LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=4d92cd373abda3937c2bc47fbc49d690 \
4 file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
5
6
7SRC_URI = "file://byte_swap.tcl"
8
9RDEPENDS += "tcl-native"
10
11inherit native
12
13S = "${WORKDIR}"
14
15do_configure[noexec] = "1"
16do_compile[noexec] = "1"
17
18do_install () {
19 install -d ${D}/${bindir}
20 install -m 755 ${WORKDIR}/byte_swap.tcl ${D}/${bindir}
21}
22
23BBCLASSEXTEND = "native nativesdk"